Bug 239150 - www/rubygem-passenger: update to 6.0.3 (6.0.2 fails to build on 11.3 with clang 8)
Summary: www/rubygem-passenger: update to 6.0.3 (6.0.2 fails to build on 11.3 with cla...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Sergey A. Osokin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-11 17:15 UTC by VVD
Modified: 2019-09-16 22:47 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (osa)


Attachments
Clang 8 support (2.79 KB, patch)
2019-07-11 17:15 UTC, VVD
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description VVD 2019-07-11 17:15:28 UTC
Created attachment 205704 [details]
Clang 8 support

11.3 amd64.

…
c++ -o buildout/apache2/module_libpassenger_common/LoggingKit.o  -Isrc/cxx_supportlib -Isrc/cxx_supportlib/vendor-copy -Isrc/cxx_supportlib/vendor-modified -Isrc/cxx_supportlib/vendor-modified/libev -Wno-ambiguous-member-template -I/usr/include/libuv -O3 -fPIC -I/usr/local/include/apr-1 -I/usr/local/include/apr-1 -I/usr/include -I/usr/local/include -I/usr/local/include/db6 -pipe -march=core2 -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -I/usr/local/include/apache24 -D_REENTRANT -I/usr/local/include -Wall -Wextra -Wno-unused-parameter -Wno-parentheses -Wpointer-arith -Wwrite-strings -Wno-long-long -Wno-missing-field-initializers -Wno-ambiguous-member-template -fvisibility=hidden -DVISIBILITY_ATTRIBUTE_SUPPORTED -DHAVE_ACCEPT4 -DHAS_SFENCE -DHAS_LFENCE -DPASSENGER_DEBUG -DBOOST_DISABLE_ASSERTS -g -fno-limit-debug-info -Wno-unused-local-typedefs -Wno-format-nonliteral -DHAS_UNORDERED_MAP -c src/cxx_supportlib/LoggingKit/Implementation.cpp                                                          
In file included from src/cxx_supportlib/LoggingKit/Implementation.cpp:46:                                                      
In file included from src/cxx_supportlib/oxt/thread.hpp:28:                                                                     
In file included from src/cxx_supportlib/vendor-modified/boost/thread.hpp:17:                                                   
In file included from src/cxx_supportlib/vendor-modified/boost/thread/once.hpp:26:                                              
In file included from src/cxx_supportlib/vendor-modified/boost/thread/pthread/once_atomic.hpp:20:
In file included from src/cxx_supportlib/vendor-modified/boost/atomic.hpp:12:
In file included from src/cxx_supportlib/vendor-modified/boost/atomic/atomic.hpp:20:
In file included from src/cxx_supportlib/vendor-modified/boost/atomic/fences.hpp:21:
In file included from src/cxx_supportlib/vendor-modified/boost/atomic/detail/operations.hpp:17:
In file included from src/cxx_supportlib/vendor-modified/boost/atomic/detail/operations_lockfree.hpp:21:
In file included from src/cxx_supportlib/vendor-modified/boost/atomic/detail/ops_gcc_atomic.hpp:24:
src/cxx_supportlib/vendor-modified/boost/atomic/detail/ops_gcc_x86_dcas.hpp:408:16: error: address argument to atomic builtin
      cannot be const-qualified ('const volatile boost::atomics::detail::gcc_dcas_x86_64::storage_type *' (aka
      'const volatile unsigned __int128 *') invalid)
        return __sync_val_compare_and_swap(&storage, value, value);
               ^                           ~~~~~~~~
1 error generated.


There is an issue https://github.com/boostorg/atomic/issues/15 with this patch: https://github.com/boostorg/atomic/commit/6e14ca24dab50ad4c1fa8c27c7dd6f1cb791b534
After apply this patch passenger build without errors.

P.S. May be we have to add issue in upstream of passenger: https://github.com/phusion/passenger/issues
Comment 1 VVD 2019-07-11 17:32:44 UTC
The cause of this error is old version of embedded boost 1.67 in passenger.
Support of clang 8 was added in the boost 1.68, current version of the boost is 1.70, release of 1.71 planned on 14th Aug.
Comment 2 VVD 2019-07-11 17:51:51 UTC
I wrote issue in the passenger's bugtracker:
https://github.com/phusion/passenger/issues/2213
Comment 3 VVD 2019-07-18 22:34:41 UTC
Passenger's developers already commited same patch, but in development branch only and nobody know about next release…
Commit, plz, this patch to ports.
Comment 4 VVD 2019-09-15 16:41:02 UTC
6.0.3 released: https://rubygems.org/gems/passenger/versions/6.0.3