Bug 239188 - editors/nano: binary package segfaults
Summary: editors/nano: binary package segfaults
Status: Closed DUPLICATE of bug 239189
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Danilo Egea Gondolfo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-13 18:06 UTC by Robert Clausecker
Modified: 2019-07-14 00:21 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (danilo)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Clausecker 2019-07-13 18:06:11 UTC
The current amd64 binary package for nano (nano-4.2) segfaults on all machines I've tried it on (all on FreeBSD-12.0).  Building the binary manually from ports fixes the problem.  Please upload a correctly built binary.
Comment 1 Robert Clausecker 2019-07-13 18:07:23 UTC
I managed to submit this one twice for some reason.  Sorry for that.

*** This bug has been marked as a duplicate of bug 239189 ***
Comment 2 s.zawadzki 2019-07-14 00:21:59 UTC
Yeah, something has wrong. You must unset LANG...

x@FreeBSD:~ % nano --version
 GNU nano, version 4.2
 (C) 1999-2011, 2013-2019 Free Software Foundation, Inc.
 (C) 2014-2019 the contributors to nano
 Email: nano@nano-editor.org	Web: https://nano-editor.org/
 Compiled options: --enable-utf8
x@FreeBSD:~ % setenv LANG pl_PL.UTF-8
x@FreeBSD:~ % nano --version
Segmentation fault (core dumped)
x@FreeBSD:~ % setenv LANG
x@FreeBSD:~ % nano --version
 GNU nano, version 4.2
 (C) 1999-2011, 2013-2019 Free Software Foundation, Inc.
 (C) 2014-2019 the contributors to nano
 Email: nano@nano-editor.org	Web: https://nano-editor.org/
 Compiled options: --enable-utf8