Bug 239200 - xorg -- no screens found, config OK
Summary: xorg -- no screens found, config OK
Status: Closed DUPLICATE of bug 239065
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on: 239065
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-14 13:15 UTC by meine
Modified: 2019-07-29 20:08 UTC (History)
2 users (show)

See Also:


Attachments
Xorg.0.log output with the error (3.34 KB, text/plain)
2019-07-14 13:15 UTC, meine
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description meine 2019-07-14 13:15:40 UTC
Created attachment 205762 [details]
Xorg.0.log output with the error

The recent update of Xorg (done on 20190713, latest version 7.7_3) gives an error that no screens are found:

vesa: Ignoring device with a bound kernel driver
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)

All settings worked well before the upgrade I did on July 13 2019, on a 64-bit system running FreeBSD 12.0-RELEASE-p7 GENERIC

Configuration files in /usr/local/etc/X11/xorg.conf.d/ are as described in the FreeBSD Handbook 5.4;

Main user is in the wheel and video group;

/boot/loader.conf contains `vesa_load="YES"';

xf86-driver-vesa is installed.

Changing settings to use and config the xf86-deriver-nv gives the same error.

Reinstalling the xorg software with `pkg install xorg' didn't resolve the problem.

Attached you'll find the output of /var/log/Xorg.0.log after starting x (startx).

TIA,

//meine
Comment 1 meine 2019-07-15 17:04:12 UTC
in my bug report where I wrote xf86-driver_*, I mean:

xf86-video-vesa
xf86-video-nv
Comment 2 meine 2019-07-29 19:46:26 UTC
downgrading libpciaccess form 0.14 to 0.13.5 resolved the problem on one of my machines, as being reported by some on the FreeBSD Forum [https://forums.freebsd.org/threads/x-no-screens-found-error.71293/page-3]

it seems that the bug I reported here has something to do with the bug on libpciaccess #239065

TIA

//meine
Comment 3 Niclas Zeising freebsd_committer 2019-07-29 20:08:23 UTC
This is a duplicate of 239065, can you add your information there?

*** This bug has been marked as a duplicate of bug 239065 ***