Bug 239213 - math/sage: Fails to build: make -j must be a positive integer
Summary: math/sage: Fails to build: make -j must be a positive integer
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Stephen Montgomery-Smith
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-15 05:08 UTC by dgilbert
Modified: 2019-11-10 21:19 UTC (History)
2 users (show)

See Also:
w.schwarzenfeld: maintainer-feedback? (stephen)
koobs: merge-quarterly?


Attachments
poudriere build log. (44.96 KB, text/plain)
2019-07-15 05:08 UTC, dgilbert
no flags Details
Patch to make MAKE_JOBS_NUMBER conditional. (405 bytes, patch)
2019-09-16 00:19 UTC, Stephen Montgomery-Smith
no flags Details | Diff
Poudriere build log with patch 3. (44.64 KB, text/plain)
2019-10-10 21:11 UTC, dgilbert
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description dgilbert 2019-07-15 05:08:45 UTC
Created attachment 205787 [details]
poudriere build log.

I've got poudriere trying to build this on 12.0, 11.2 and 11.3.  They all seem to stop with this line in the log:

make[2]: illegal argument to -j -- must be positive integer!

I've attached poudriere's log.

I thought this might have been due to ALLOW_MAKE_JOBS being yes on my poudriere, but I confirmed this is not the case by running a build with it set to no.

make file wierdness is a weakness of mine... so I haven't yet figured out the problem.
Comment 1 Stephen Montgomery-Smith freebsd_committer 2019-09-15 22:42:57 UTC
Comment on attachment 205787 [details]
poudriere build log.

Are you able to do the following?

make -V MAKE_JOBS_NUMBER
Comment 2 dgilbert 2019-09-15 23:45:35 UTC
(In reply to Stephen Montgomery-Smith from comment #1)

How do I cause poudriere to do that?
Comment 3 Stephen Montgomery-Smith freebsd_committer 2019-09-15 23:50:35 UTC
I don't know.  I don't use poudriere.  This lack of control is one of the reasons why I don't use it.

Try the attached patch.  This is just a band aid solution, but it will give me some idea of where the problem might be.

This patch won't apply cleanly because of white space issues, but it involves editing one line, so you should be able to do it by hand.

Index: Makefile
===================================================================
--- Makefile    (revision 512126)
+++ Makefile    (working copy)
@@ -98,7 +98,7 @@
 
 .include <bsd.port.pre.mk>
 
-MAKE_ENV+=     MAKE="${MAKE} -j${MAKE_JOBS_NUMBER}"
+MAKE_ENV+=     MAKE="${MAKE} -j1"
 
 .ifdef MAINTAINER_MODE
 test-fbsd-patches:     patch
Comment 4 Stephen Montgomery-Smith freebsd_committer 2019-09-16 00:19:19 UTC
Created attachment 207527 [details]
Patch to make MAKE_JOBS_NUMBER conditional.
Comment 5 Stephen Montgomery-Smith freebsd_committer 2019-09-16 00:20:41 UTC
If the patch in comment 3 works, try the patch given in comment 4.  (Don't forget to revert the other patch first.)
Comment 6 dgilbert 2019-10-10 21:11:21 UTC
Created attachment 208233 [details]
Poudriere build log with patch 3.

neither patch 3 or patch 4 work.  I'm loading the patch3 log since the patch is simpler and more direct.
Comment 7 Stephen Montgomery-Smith freebsd_committer 2019-11-10 21:19:23 UTC
This port is getting very old, and I am not doing a good job maintaining it.  And just recently, the source code of the current version is so old it can no longer download it.

It is a very hard port to maintain because it builds its own dependencies.  And patches have to be applied to tar balls contained in the download.  And I don't have a lot of time to work on it.

So I'm going to depreciate this port.  Anyone who wants to take over is welcome.

Sorry.