Bug 239224 - Virtual Interface: Not Working in Netmap Mode on 11.3 STABLE
Summary: Virtual Interface: Not Working in Netmap Mode on 11.3 STABLE
Status: Closed DUPLICATE of bug 238642
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.3-STABLE
Hardware: Any Any
: --- Affects Many People
Assignee: Vincenzo Maffione
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-07-15 13:25 UTC by Charles Goncalves
Modified: 2019-07-16 18:42 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles Goncalves 2019-07-15 13:25:55 UTC
Hello!

I was trying to update my servers from FreeBSD 11.2-STABLE to 11.3-STABLE and first a tested Netmap on top of 11.3-STABLE. My application did a Kernel Panic on my first try.

First I thought my application was wrong so I tried netmap/apps in Virtual Interfaces like(VLAN/TAP/TUN):

pkt-gen -f rx -i vlan5 (Kernel Panic. Server reboot)
pkt-gen -f rx -i tap5 (Kernel Panic. Server reboot)
pkt-gen -f rx -i tun5 (Kernel Panic. Server reboot)

vale-ctl -h vale0:vlan5 (Kernal Panic. Server reboot)
vale-ctl -h vale0:tap5 (Kernal Panic. Server reboot)
vale-ctl -h vale0:tun5 (Kernal Panic. Server reboot)

So I tried with tcpdump:
tcpdump -eni netmap:vlan5 (Kernal Panic. Server reboot)
tcpdump -eni netmap:tap5 (Kernal Panic. Server reboot)
tcpdump -eni netmap:tun5 (Kernal Panic. Server reboot)

This tests is full working in my FreeBSD 11.2-STABLE, but is not working in FreeBSD 11.3-STABLE
Comment 1 Vincenzo Maffione freebsd_committer 2019-07-15 16:07:17 UTC
Hi,
  Maybe you hit the bug introduced by r349922 (fixed in HEAD, will MFC today)?
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=238642 
Can you check if the stack trace is the same?
Comment 2 Charles Goncalves 2019-07-15 18:55:24 UTC
(In reply to Vincenzo Maffione from comment #1)
Yeah it’s the same bug when a run command like Aleksandr Fedorov:

root@current:~ # ifconfig vlan0 create up                                                                                                                                
root@current:~ # vale-ctl -a vale0:vlan0


I’m running on FreeBSD 11.3-STABLE #0 r349942
Comment 3 Vincenzo Maffione freebsd_committer 2019-07-15 20:16:05 UTC
I just committed the fix as r350007.
Can you please try again?
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2019-07-16 01:27:58 UTC
Panic report & regression reported in bug 238642 (which was/is still open at the time of this report), so close this as a duplicate

*** This bug has been marked as a duplicate of bug 238642 ***
Comment 5 Charles Goncalves 2019-07-16 18:42:07 UTC
(In reply to Vincenzo Maffione from comment #3)
Works fine now on FreeBSD 11.3-STABLE r350026

Thank you!