Bug 239233 - archivers/arj: Fails to fetch from Debian mirror and fails to build
Summary: archivers/arj: Fails to fetch from Debian mirror and fails to build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Renato Botelho
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2019-07-16 01:46 UTC by Darin Luckie
Modified: 2019-07-17 11:43 UTC (History)
1 user (show)

See Also:
koobs: maintainer-feedback? (garga)


Attachments
ARJ Build Fail (12.02 KB, text/plain)
2019-07-16 01:46 UTC, Darin Luckie
no flags Details
PKG Version -v (15.35 KB, text/plain)
2019-07-16 02:30 UTC, Darin Luckie
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Luckie 2019-07-16 01:46:47 UTC
Created attachment 205812 [details]
ARJ Build Fail

Unable to fetch arj from debian mirror. Moved an old distfile via SCP and does not appear to build on FreeBSD 12-RELEASE inswide a jail. Has worked on 12-RELEASE previously.

Log attached.

gmake[3]: *** [GNUmakefile:258: freebsd12.0/en/rs/msg_crp.h] Abort trap
gmake[3]: Leaving directory '/var/ports/basejail/usr/ports/archivers/arj/work/arj-3.10.22'
gmake[2]: *** [GNUmakefile:169: all] Error 2
gmake[2]: Leaving directory '/var/ports/basejail/usr/ports/archivers/arj/work/arj-3.10.22'
*** Error code 1
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-07-16 01:50:49 UTC
Thank you for the report Darin

Could you please include:

- Exact FreeBSD version (uname -a)
- pkg version -v output (as an attachment)
- Confirmation that the issue is reproducible with the latest ports tree (via portsnap or svn)
Comment 2 Darin Luckie 2019-07-16 02:30:31 UTC
Created attachment 205813 [details]
PKG Version -v
Comment 3 Darin Luckie 2019-07-16 02:32:11 UTC
(In reply to Kubilay Kocak from comment #1)


root@mx:~ # uname -a
FreeBSD mx.technotic.ca 12.0-RELEASE-p7 FreeBSD 12.0-RELEASE-p7 GENERIC  amd64

root@mx:/usr/local/etc/openvpn/easy-rsa # ezjail-admin update -P
Looking up portsnap.FreeBSD.org mirrors... 6 mirrors found.
Fetching snapshot tag from your-org.portsnap.freebsd.org... done.
Latest snapshot on server matches what we already have.
No updates needed.
Ports tree is already up to date.

Issue is reproducible on latest ports, indeed!
Comment 4 commit-hook freebsd_committer 2019-07-16 18:47:03 UTC
A commit references this bug:

Author: garga
Date: Tue Jul 16 18:46:48 UTC 2019
New revision: 506777
URL: https://svnweb.freebsd.org/changeset/ports/506777

Log:
  archivers/arj: Unbreak upgrading debian patchset

  Version 17 of debian patches is not available anymore.  Upgrade it to use
  version 21 and fix the build

  PR:		239233
  Reported by:	Darin Luckie <darin@technotic.ca>
  MFH:		2019Q3
  Sponsored by:	Rubicon Communications, LLC (Netgate)

Changes:
  head/archivers/arj/Makefile
  head/archivers/arj/distinfo
Comment 5 commit-hook freebsd_committer 2019-07-17 11:43:31 UTC
A commit references this bug:

Author: garga
Date: Wed Jul 17 11:43:23 UTC 2019
New revision: 506797
URL: https://svnweb.freebsd.org/changeset/ports/506797

Log:
  MFH: r506777

  archivers/arj: Unbreak upgrading debian patchset

  Version 17 of debian patches is not available anymore.  Upgrade it to use
  version 21 and fix the build

  PR:		239233
  Reported by:	Darin Luckie <darin@technotic.ca>
  Sponsored by:	Rubicon Communications, LLC (Netgate)
  Approved by:	ports-secteam (miwi)

Changes:
_U  branches/2019Q3/
  branches/2019Q3/archivers/arj/Makefile
  branches/2019Q3/archivers/arj/distinfo