Bug 239276 - net-mgmt/prometheus2: Update to 2.11.1
Summary: net-mgmt/prometheus2: Update to 2.11.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-17 22:30 UTC by David O'Rourke
Modified: 2019-07-19 13:51 UTC (History)
0 users

See Also:
dor.bsd: maintainer-feedback+


Attachments
net-mgmt/prometheus2: Update to 2.11.1 (1.82 KB, patch)
2019-07-17 22:30 UTC, David O'Rourke
dor.bsd: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David O'Rourke 2019-07-17 22:30:05 UTC
Created attachment 205854 [details]
net-mgmt/prometheus2: Update to 2.11.1

This patch updates net-mgmt/prometheus2 to 2.11.1, fixing a potential panic when prometheus is watching multiple zookeeper paths.

Additionally:
  - The GO_BUILDFLAGS were fixed, restoring some missing information to the "Runtime build and information" page of the UI, this was caused by the switch to USES=go:modules and the resulting change in paths at compile time.
  - We simplified GO_TARGET a little by removing the now redundant PROMETHEUS_BINARIES variable. This was previously used in a do-install for loop that was removed in a previous revision of the port.

The port passes portlint and poudriere testport.

-David
Comment 1 commit-hook freebsd_committer 2019-07-19 13:51:04 UTC
A commit references this bug:

Author: swills
Date: Fri Jul 19 13:50:20 UTC 2019
New revision: 506934
URL: https://svnweb.freebsd.org/changeset/ports/506934

Log:
  net-mgmt/prometheus2: Update to 2.11.1

  PR:		239276
  Submitted by:	David O'Rourke <dor.bsd@xm0.uk> (maintainer)

Changes:
  head/net-mgmt/prometheus2/Makefile
  head/net-mgmt/prometheus2/distinfo
Comment 2 Steve Wills freebsd_committer 2019-07-19 13:51:24 UTC
Committed, thanks!