Bug 239314 - graphics/embree: Update to v3.5.2
Summary: graphics/embree: Update to v3.5.2
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2019-07-19 18:10 UTC by kunda
Modified: 2019-08-23 00:43 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments
update graphics/embree to 3.6.0.beta.0 (19.37 KB, patch)
2019-08-14 03:46 UTC, Shane
no flags Details | Diff
update graphics/embree to 3.6.0 release (19.21 KB, patch)
2019-08-23 00:43 UTC, Shane
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description kunda 2019-07-19 18:10:57 UTC
https://github.com/embree/embree/releases/tag/v3.5.2

After update Bug #236144 needs to be tested to see if still valid
Comment 1 Shane 2019-08-14 03:46:18 UTC
Created attachment 206512 [details]
update graphics/embree to 3.6.0.beta.0

I want to update this port, to be added later as a dependency for graphics/blender and I am willing to take maintainership.

As I am updating this now to prevent this port being deleted and the current dependents will remain broken until updated to work with v3.x I have started the new version at 3.6.0 beta rather than the stable release.

While the readme states support for win32, other systems have only 64 bit support so I have made no effort to support 32bit.

The previous version installed the "tutorial" demo binaries into ${LOCALBASE}bin/embree2, I have moved these into ${EMAPLESDIR} as a more appropriate location.
Comment 2 Alexey Dokuchaev freebsd_committer 2019-08-20 08:52:31 UTC
(In reply to Shane from comment #1)

> As I am updating this now to prevent this port being deleted
Actually, to unbreak it, I believe all that's needed is to remove ISPC option from the defaults

> have started the new version at 3.6.0 beta rather than the stable release.
Any reason for this?  Typically, we prefer to track stable releases in the FreeBSD Ports Collection.

Thanks for working on this, I'll take a look as my time permits.
Comment 3 Shane 2019-08-21 05:51:12 UTC
(In reply to Alexey Dokuchaev from comment #2)

Actually I did have the existing v2.17.6 port built and installed, as blender wants v3 libs I wanted to make v3 available. There was a v2.17.7 tagged back in feb which is in between v3 releases. I wonder if I might also make en embree2 port to keep support for existing ports.

With 3.6.0, and linking against blender, I see no difference with ISPC enabled or disabled. I left it out of defaults only to not bring llvm as a dep.

I started with the recent beta tag as I don't expect the port to be used straight away, and expected the stable release before anyone started using it. As it was tagged today, I will update the patch to the stable release soon.
Comment 4 Shane 2019-08-23 00:43:50 UTC
Created attachment 206808 [details]
update graphics/embree to 3.6.0 release

Adjust for 3.6.0 release