Bug 239383 - java/openjdk11 configure: error: Could not find all X11 headers in poudriere
Summary: java/openjdk11 configure: error: Could not find all X11 headers in poudriere
Status: Closed DUPLICATE of bug 239387
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-java (Nobody)
URL:
Keywords:
Depends on: 239387
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-22 19:13 UTC by Robert Cina
Modified: 2019-07-24 22:46 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (java)


Attachments
java/openjdk11 poudriere build log (38.29 KB, text/plain)
2019-07-22 19:13 UTC, Robert Cina
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cina 2019-07-22 19:13:22 UTC
Created attachment 205996 [details]
java/openjdk11 poudriere build log

I am getting a poudriere configure error where all X11 headers are not found when building the port for java/openjdk11.

Below is the output of the error and i have included the build log as attachment:

checking for X11/extensions/XTest.h... yes
checking for X11/Intrinsic.h... yes
checking for X11/extensions/Xrandr.h... no
configure: error: Could not find all X11 headers (shape.h Xrender.h Xrander.h XTest.h Intrinsic.h). 
configure exiting with result code 1
===>  Script "configure" failed unexpectedly.
Please report the problem to java@FreeBSD.org [maintainer] and attach the
"/wrkdirs/usr/ports/java/openjdk11/work/openjdk-jdk11u-jdk-11.0.4-11-1/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/java/openjdk11
=>> Cleaning up wrkdir
===>  Cleaning for openjdk11-11.0.4+11.1
build of java/openjdk11 | openjdk11-11.0.4+11.1 ended at Mon Jul 22 15:07:33 EDT 2019
build time: 00:00:28
!!! build failure encountered !!!
Comment 1 Jonathan Chen 2019-07-22 21:47:29 UTC
Patches to fix build in:

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=239387
Comment 2 Greg Lewis freebsd_committer 2019-07-24 22:46:18 UTC
Duplicate of bug 239387

*** This bug has been marked as a duplicate of bug 239387 ***