Bug 239384 - java/openjdk11 configure error: /usr/local/libexec/ccache/cc is a symbolic link to ccache. This is not supported.
Summary: java/openjdk11 configure error: /usr/local/libexec/ccache/cc is a symbolic li...
Status: Closed DUPLICATE of bug 239387
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-java (Nobody)
URL:
Keywords:
Depends on: 239387
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-22 19:20 UTC by Robert Cina
Modified: 2019-07-24 22:47 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (java)


Attachments
java/openjdk11 poudriere build log (35.39 KB, text/plain)
2019-07-22 19:20 UTC, Robert Cina
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cina 2019-07-22 19:20:41 UTC
Created attachment 205997 [details]
java/openjdk11 poudriere build log

When building java/openjdk11 with ccache enabled for poudriere I get a configure error with this port. The configure error is /usr/local/libexec/ccache/cc being a symbolic link to ccache which is not supported.

Below is the poudriere log output for the configure error and attached is the poudriere build log.

configure: Will use user supplied compiler CC=cc
checking for cc... /usr/local/libexec/ccache/cc
checking resolved symbolic links for CC... /usr/local/bin/ccache
configure: Please use --enable-ccache instead of providing a wrapped compiler.
configure: error: /usr/local/libexec/ccache/cc is a symbolic link to ccache. This is not supported.
configure exiting with result code 1
===>  Script "configure" failed unexpectedly.
Please report the problem to java@FreeBSD.org [maintainer] and attach the
"/wrkdirs/usr/ports/java/openjdk11/work/openjdk-jdk11u-jdk-11.0.4-11-1/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/java/openjdk11
=>> Cleaning up wrkdir
===>  Cleaning for openjdk11-11.0.4+11.1
build of java/openjdk11 | openjdk11-11.0.4+11.1 ended at Mon Jul 22 15:15:55 EDT 2019
build time: 00:00:28
!!! build failure encountered !!!
Comment 1 Jonathan Chen 2019-07-22 21:46:41 UTC
Patches to fix build in:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=239387
Comment 2 Greg Lewis freebsd_committer 2019-07-24 22:47:59 UTC

*** This bug has been marked as a duplicate of bug 239387 ***