Bug 239387 - java/openjdk11: Fix build failures for 11.0.4+11.1
Summary: java/openjdk11: Fix build failures for 11.0.4+11.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-java mailing list
URL:
Keywords:
: 239383 239384 (view as bug list)
Depends on:
Blocks: 239383 239384
  Show dependency treegraph
 
Reported: 2019-07-22 21:45 UTC by Jonathan Chen
Modified: 2019-07-24 22:48 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (java)


Attachments
Fix Build (424 bytes, patch)
2019-07-22 21:45 UTC, Jonathan Chen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Chen 2019-07-22 21:45:05 UTC
Created attachment 205998 [details]
Fix Build

The attached patch fixes:

 * missing X11 headers during configure.
 * disables CCACHE for ccache-enabled build systems.
Comment 1 commit-hook freebsd_committer 2019-07-24 22:41:43 UTC
A commit references this bug:

Author: glewis
Date: Wed Jul 24 22:41:41 UTC 2019
New revision: 507303
URL: https://svnweb.freebsd.org/changeset/ports/507303

Log:
  * Add a dependency on xrandr, since the latest version uses Xrandr.h
  * Set NO_CCACHE to match configure being passed --disable-ccache

  Fixes the build in poudriere and for people trying to use ccache

  PR:		239387
  Submitted by:	Jonathan Chen <jonc@chen.org.nz>

Changes:
  head/java/openjdk11/Makefile
Comment 2 commit-hook freebsd_committer 2019-07-24 22:45:45 UTC
A commit references this bug:

Author: glewis
Date: Wed Jul 24 22:45:29 UTC 2019
New revision: 507304
URL: https://svnweb.freebsd.org/changeset/ports/507304

Log:
  * Set NO_CCACHE to match configure being passed --disable-ccache

  Fixes the build for people trying to use ccache

  PR:		239387
  Submitted by:	Jonathan Chen <jonc@chen.org.nz>

Changes:
  head/java/openjdk12/Makefile
Comment 3 Greg Lewis freebsd_committer 2019-07-24 22:46:18 UTC
*** Bug 239383 has been marked as a duplicate of this bug. ***
Comment 4 Greg Lewis freebsd_committer 2019-07-24 22:47:48 UTC
Thanks!  I've committed the changes
Comment 5 Greg Lewis freebsd_committer 2019-07-24 22:47:59 UTC
*** Bug 239384 has been marked as a duplicate of this bug. ***