Bug 239402 - efifb ignored under 11.3 and later
Summary: efifb ignored under 11.3 and later
Status: Closed DUPLICATE of bug 241036
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 11.3-RELEASE
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-23 12:58 UTC by Mason Loring Bliss
Modified: 2019-10-21 19:34 UTC (History)
2 users (show)

See Also:


Attachments
Image of console exhibiting issue. (43.01 KB, image/png)
2019-07-23 12:58 UTC, Mason Loring Bliss
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mason Loring Bliss 2019-07-23 12:58:28 UTC
Created attachment 206008 [details]
Image of console exhibiting issue.

I was installing a VM last night under QEMU/KVM with OVMF for purposes of looking at offline VM migration between this environment and Bhyve, and I thought at first that my VM had locked up. RhodiumToad from Freenode suggested that it hadn't locked up, but that it was using a console I wasn't looking at, and he nailed it - I was able to interact on the VM's serial console.

I noted this behaviour on install disks from all of: 11.3-RELEASE, 12.0-RELEASE, 12-STABLE, and 13-CURRENT. Trying the 11.2-RELEASE install disk, the efifb is used by default.

Something I noted was that 11.2-RELEASE shows the Beastie logo in colour, whereas the newer installers show it in black and white.

Another slight oddity is that when I opted for a live session from the serial console, I noticed a functional getty showing up on the efifb, so it seems like the efifb works but simply isn't preferred under 11.3 and newer.

While this behaviour is pretty easy to accomodate, it was surprising, and I didn't know to look at the serial console at first. I haven't tracked down just why it's happening, but I'd be happy to help explore this.

I've attached an image of the efifb console at the point when the system starts using the serial console exclusively.
Comment 1 Kyle Evans freebsd_committer 2019-07-23 13:02:51 UTC
CC imp; I suspect this to be the result of console detection changes in efiland.
Comment 2 Mason Loring Bliss 2019-07-23 13:16:47 UTC
As a random additional note, it's conceivably specific to OVMF, as I've got EFI installs of 12 on two bare-metal systems here that didn't exhibit this behaviour.
Comment 3 Mason Loring Bliss 2019-07-23 13:36:40 UTC
Additional notes:

Not sure where this behaviour lies, but virt-manager has an option for opening
the serial console which fails, and which precludes subsequent attempts to open
the serial console via other methods.

More notable and interesting, once the VM is completely installed, it retains
this behaviour, ignoring the efifb and using the serial console, except that as
noted previously, a functioning getty does spawn on the efifb.
Comment 4 Mason Loring Bliss 2019-10-21 19:34:15 UTC
I'm closing this, as I've reported it again in 241036, and it's seeing attention
there. I evidently forgot I'd opened this one here. Ah, well.

*** This bug has been marked as a duplicate of bug 241036 ***