Bug 239426 - x11/nvidia-driver: make index problem
Summary: x11/nvidia-driver: make index problem
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL: https://lists.freebsd.org/pipermail/f...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-24 17:40 UTC by gja822
Modified: 2019-09-21 11:30 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gja822 2019-07-24 17:40:18 UTC
After portsnap fetch update (or portsnap fetch extract), due to some options in make.conf, I get the error:

Building new INDEX files... done.
Generating INDEX-11 - please wait..--- describe.accessibility ---
--- describe.arabic ---
--- describe.archivers ---
--- describe.astro ---
--- describe.audio ---
--- describe.benchmarks ---
--- describe.biology ---
--- describe.cad ---
--- describe.chinese ---
--- describe.comms ---
--- describe.converters ---
--- describe.databases ---
--- describe.deskutils ---
--- describe.devel ---
--- describe.dns ---
--- describe.editors ---
--- describe.emulators ---
--- describe.finance ---
--- describe.french ---
--- describe.ftp ---
--- describe.games ---
--- describe.german ---
--- describe.graphics ---
--- describe.hebrew ---
--- describe.hungarian ---
--- describe.irc ---
--- describe.japanese ---
--- describe.java ---
--- describe.korean ---
--- describe.lang ---
--- describe.mail ---
--- describe.math ---
--- describe.misc ---
--- describe.multimedia ---
--- describe.net ---
--- describe.net-im ---
--- describe.net-mgmt ---
--- describe.net-p2p ---
--- describe.news ---
--- describe.palm ---
--- describe.polish ---
--- describe.ports-mgmt ---
--- describe.portuguese ---
--- describe.print ---
--- describe.russian ---
--- describe.science ---
--- describe.security ---
--- describe.shells ---
--- describe.sysutils ---
--- describe.textproc ---
--- describe.ukrainian ---
--- describe.vietnamese ---
--- describe.www ---
--- describe.x11 ---
--- describe.x11-clocks ---
--- describe.x11-drivers ---
--- describe.x11-fm ---
--- describe.x11-fonts ---
--- describe.x11-servers ---
--- describe.x11-themes ---
--- describe.x11-toolkits ---
--- describe.x11-wm ---
make_index: /usr/ports/x11/nvidia-driver: no entry for /usr/ports/graphics/linux-c6-libglvnd
 Done.

It is the problem I've mentioned on the forum
https://forums.freebsd.org/threads/make-index-do-not-make-index.71487/
Comment 2 gja822 2019-07-25 03:03:16 UTC
(In reply to Mark Linimon from comment #1)
I had no linux at all in DEFAULT_VERSIONS a long time ago, more than a year (you can see it from my make.conf contents on the forums). And I have rebuilt all linux ports without luck. And yes, I've seen that lines in /usr/ports/UPDATING
Comment 3 gja822 2019-07-25 03:07:11 UTC
(In reply to gja822 from comment #2)
The only "linux" is linux_enable="YES" in rc.conf for me.
Comment 4 gja822 2019-07-25 06:06:26 UTC
May be "Component" should be different? Say, Package infrastructure?
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2019-07-25 17:45:34 UTC
No, it is a problem with an individual port.

"ports framework" is only for files in e.g. ports/Mk.

"ports infrastructure" is only for machines located at FreeBSD.org.  It is intended for FreeBSD.org internal use only.
Comment 6 Ben Woods freebsd_committer 2019-09-21 11:30:39 UTC
Is this bug still an issue, or has it been fixed with the following note in UPDATING?
https://svnweb.freebsd.org/ports/head/UPDATING?r1=506352&r2=506351&pathrev=506352