Bug 239439 - emulators/mame: Upgrade to 0.212
Summary: emulators/mame: Upgrade to 0.212
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-25 08:32 UTC by checo1705
Modified: 2019-08-14 19:21 UTC (History)
2 users (show)

See Also:


Attachments
2.09 > 2.11 diff (27 bytes, patch)
2019-07-25 08:32 UTC, checo1705
no flags Details | Diff
The diff (5.09 KB, patch)
2019-07-25 08:34 UTC, checo1705
no flags Details | Diff
New Patch (5.41 KB, patch)
2019-08-10 22:57 UTC, checo1705
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description checo1705 2019-07-25 08:32:29 UTC
Created attachment 206052 [details]
2.09 > 2.11 diff

Cleaned up patches added already to source, a makefile which is no long anymore and plisted files on hashes. It did not compile with static libpugixml but worked fine with our port so had to made it a dependency.
Comment 1 checo1705 2019-07-25 08:34:21 UTC
Created attachment 206054 [details]
The diff
Comment 2 checo1705 2019-08-10 22:57:01 UTC
Created attachment 206430 [details]
New Patch

New patch that upgrades to 0.212 and takes in account revision 507824
Comment 3 sirdice 2019-08-14 19:21:02 UTC
Thanks for the patch! You beat me to it actually. I was planning on taking over as maintainer at the same time.

I'm wondering what your build issues were though. I didn't encounter any problems with libpugixml. So my patch wouldn't have included this. 

If you update emulators/mame you need to update emulators/mess too. Mess is a slave port but has its own pkg-plist. No idea why that separate mess port still exists. One of my first tasks as maintainer would be to remove that port. Second on the list is adding options to switch to 'arcade only' and making the tools (chdman, etc) optional. Third on the list is switching to Python 3.6. Already tried that but it's been giving me weird conversion errors. 

I would be very happy to help out if you want to take ownership. I'd be equally happy if you help out if I take the maintainer role.