Bug 239442 - share/man/man5/src.conf.5: remove redundant paragraphs for {WITH,WITHOUT}_PROFILE
Summary: share/man/man5/src.conf.5: remove redundant paragraphs for {WITH,WITHOUT}_PRO...
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Manual Pages (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2019-07-25 11:23 UTC by Robert Schulze
Modified: 2019-09-05 14:57 UTC (History)
3 users (show)

See Also:


Attachments
remove redundant paragraphs for PROFILE (1.37 KB, patch)
2019-07-25 11:23 UTC, Robert Schulze
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Schulze 2019-07-25 11:23:41 UTC
Created attachment 206059 [details]
remove redundant paragraphs for PROFILE

The manual page for src.conf contains four consecutive paragraphs for WITH_PROFILE/WITHOUT_PROFILE. This patch removes all of them except the first one.
Comment 1 Ed Maste freebsd_committer 2019-07-25 21:44:58 UTC
src.conf.5 is generated by tools/build/options/makeman, so the fix will need to be done there

I also see only one instance of WITHOUT_PROFILE on HEAD:

% grep -c WITHOUT_PROFILE share/man/man5/src.conf.5      
1

On which version did you observe this?
Comment 2 Robert Schulze 2019-07-26 07:46:03 UTC
(In reply to Ed Maste from comment #1)

This issue is present in 11.2, I did not check 12 or HEAD.
If this is already fixed, this PR can be closed.
Comment 3 Benedict Reuschling freebsd_committer 2019-09-05 14:57:06 UTC
I can confirm that the issue is no longer present in src.conf, closing this PR.