Bug 239469 - net/knxd: fix build with GCC architectures
Summary: net/knxd: fix build with GCC architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Matthias Fechner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-26 22:30 UTC by Piotr Kubaj
Modified: 2019-08-25 08:31 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (mfechner)


Attachments
patch (933 bytes, patch)
2019-07-26 22:30 UTC, Piotr Kubaj
pkubaj: maintainer-approval? (mfechner)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-07-26 22:30:40 UTC
Created attachment 206092 [details]
patch

ENODATA is not defined when using GCC. Use the value that boost headers specify (9919) if ENODATA is not defined to fix build.
Comment 1 Matthias Fechner freebsd_committer 2019-07-27 15:47:10 UTC
Have you tried to get the included upstream?
I prefer to get it included upstream and upgrade the port then to this version.
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2019-07-27 15:54:24 UTC
(In reply to Matthias Fechner from comment #1)

We've been working on hundreds of ports on ppcp64, so, in generally, no we haven't.  We do need help with that part.
Comment 3 Matthias Fechner freebsd_committer 2019-07-27 16:00:14 UTC
(In reply to Mark Linimon from comment #2)
ok so the problem is that it does not compile using gcc for ppc?

I will try to raise a CR upstream.
Comment 4 Matthias Fechner freebsd_committer 2019-07-27 16:10:27 UTC
PR upstream:
https://github.com/knxd/knxd/pull/407
Comment 5 Piotr Kubaj freebsd_committer 2019-08-24 12:36:05 UTC
(In reply to Matthias Fechner from comment #4)
Can we commit this patch for now in FreeBSD ports?
Comment 6 commit-hook freebsd_committer 2019-08-25 08:31:05 UTC
A commit references this bug:

Author: mfechner
Date: Sun Aug 25 08:31:00 UTC 2019
New revision: 509778
URL: https://svnweb.freebsd.org/changeset/ports/509778

Log:
  net/knxd: fix build with GCC architectures.

  This patch is also requested upstream:
  https://github.com/knxd/knxd/pull/407

  PR:		239469
  Submitted by:	pkubaj

Changes:
  head/net/knxd/files/patch-src_libserver_eibnetip.cpp
Comment 7 Matthias Fechner freebsd_committer 2019-08-25 08:31:48 UTC
Thanks.