Bug 239528 - devel/protobuf: update to 3.9.0
Summary: devel/protobuf: update to 3.9.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Po-Chuan Hsieh
URL: https://people.FreeBSD.org/~sunpoet/p...
Keywords:
Depends on:
Blocks: 239038
  Show dependency treegraph
 
Reported: 2019-07-30 15:46 UTC by Po-Chuan Hsieh
Modified: 2019-07-31 16:40 UTC (History)
0 users

See Also:
antoine: exp-run+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Po-Chuan Hsieh freebsd_committer 2019-07-30 15:46:11 UTC
Update devel/protobuf to 3.9.0

Changes:        https://github.com/protocolbuffers/protobuf/releases
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-07-31 10:50:22 UTC
@Sunpoet Please include PR references (and comments in the commit log) with this update for bug 239550 (the root cause base bug) and bug 239038 (the bug this update fixes) so that our future selves have the full context of the issue.
Comment 2 Antoine Brodin freebsd_committer 2019-07-31 11:12:35 UTC
Exp-run looks fine
Comment 3 commit-hook freebsd_committer 2019-07-31 16:37:37 UTC
A commit references this bug:

Author: sunpoet
Date: Wed Jul 31 16:37:22 UTC 2019
New revision: 507716
URL: https://svnweb.freebsd.org/changeset/ports/507716

Log:
  Update to 3.9.0

  - Fix regular expression: it causes problem when gtest/gmock is not the first one in a line, e.g. src/Makefile.in:673

  Changes:	https://github.com/protocolbuffers/protobuf/releases
  PR:		239528
  Exp-run by:	antoine

Changes:
  head/devel/protobuf/Makefile
  head/devel/protobuf/distinfo
  head/devel/protobuf/pkg-plist
Comment 4 Po-Chuan Hsieh freebsd_committer 2019-07-31 16:40:27 UTC
Committed. Thanks!