Bug 239553 - science/InsightToolkit: fix build with GCC-based architectures
Summary: science/InsightToolkit: fix build with GCC-based architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ben Woods
URL:
Keywords:
: 239765 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-31 09:28 UTC by Piotr Kubaj
Modified: 2019-09-30 14:16 UTC (History)
1 user (show)

See Also:
woodsb02: maintainer-feedback+


Attachments
patch (487 bytes, patch)
2019-07-31 09:28 UTC, Piotr Kubaj
no flags Details | Diff
v2 (1.27 KB, patch)
2019-08-24 12:47 UTC, Piotr Kubaj
pkubaj: maintainer-approval? (woodsb02)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-07-31 09:28:31 UTC
Created attachment 206173 [details]
patch

After the switch to GCC9, it's necessary to expand the ifdef.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2019-08-02 16:34:07 UTC
This builds for me on both amd64 and powerpc64.
Comment 2 Ben Woods freebsd_committer 2019-08-04 03:17:23 UTC
Hi pkubaj@ and linimon@,
Thanks for the bug report, and for the patch (always love it when bugs come with patches).

However, as of today I suspect this could be "overcome by events". I just updated the port science/InsightToolkit to version 5.0.1 and this has removed the local patch that is being updated here entirely.
https://svnweb.freebsd.org/changeset/ports/508047

Given that the 2019Q3 ports quarterly branch still uses GCC=8 by default, this patch was only necessary in the port head branch.
https://svnweb.freebsd.org/ports/branches/2019Q3/Mk/bsd.default-versions.mk?view=markup

If the new version of science/InsightToolkit version 5.0.1  does not need this patch, then I think we can close this bug (can you please confirm?).
Comment 3 Piotr Kubaj freebsd_committer 2019-08-24 12:47:00 UTC
Created attachment 206846 [details]
v2

Now plist changes when compiler is GCC.
Comment 4 Piotr Kubaj freebsd_committer 2019-09-04 09:31:17 UTC
*** Bug 239765 has been marked as a duplicate of this bug. ***
Comment 5 Piotr Kubaj freebsd_committer 2019-09-30 14:16:57 UTC
Already committed.