Bug 239585 - math/openblas: Build failed with "Access to an undefined portion of a memory object"
Summary: math/openblas: Build failed with "Access to an undefined portion of a memory ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-01 23:54 UTC by Igor Pavlov
Modified: 2020-05-01 17:24 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (phd_kimberlite)


Attachments
Build log (178.48 KB, application/zip)
2019-08-01 23:54 UTC, Igor Pavlov
no flags Details
OpenBlas 0.3.6 (16.92 KB, text/plain)
2019-10-19 06:54 UTC, Eijiro Shibusawa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Pavlov 2019-08-01 23:54:53 UTC
Created attachment 206210 [details]
Build log

Build failed with the following error:

 END OF TESTS
OMP_NUM_THREADS=1 OMP_NUM_THREADS=1 ./zblat2 < ./zblat2.dat

Program received signal SIGBUS: Access to an undefined portion of a memory object.

Backtrace for this error:

Could not print backtrace: libbacktrace could not find executable to open
#0  0x80081fc6a
#1  0x80081eb15
#2  0x7ffffffff172
#3  0x427ed1
#4  0x4282b1
#5  0x413b0a
#6  0x40d30d
#7  0x4133fb
#8  0x40123e
#9  0x40137a
#10  0x800660fff
gmake[3]: *** [Makefile:36: level2] Bus error (core dumped)
gmake[3]: Leaving directory '/usr/ports/math/openblas/work/OpenBLAS-0.2.20/test'
gmake[2]: *** [Makefile:117: tests] Error 2
gmake[2]: Leaving directory '/usr/ports/math/openblas/work/OpenBLAS-0.2.20'
*** Error code 2

Stop.
make[1]: stopped in /usr/ports/math/openblas
*** Error code 1

Stop.
make: stopped in /usr/ports/math/openblas


Build log attached.
Comment 1 eborisch+FreeBSD 2019-08-05 20:09:29 UTC
Not just you -- I'm getting a very similar error. It goes away if I don't use OPENMP; so that might be a place to start looking.
Comment 2 Eijiro Shibusawa 2019-10-19 06:54:44 UTC
Created attachment 208416 [details]
OpenBlas 0.3.6

Hi, I have similar problem too and have created a minimum update for the port.
This problem seems to be solved in the latest.
Please try the attached port.

Currently I have no plan to merge the attached.
I am waiting for the following header file installation patch (BUG #238228) is commited.
Comment 3 Thomas Guymer 2019-11-16 07:54:06 UTC
I just experienced this too whilst I was rebuilding all of my ports after I upgraded to 12.1-RELEASE. Deselecting the OPENMP option allowed me to build it.
Comment 4 Eijiro Shibusawa 2020-05-01 10:09:49 UTC
Hi, submitter,
Could you report back if the latest port works for you?
If the issue solved please close this PR.
Thanks!
Comment 5 Thomas Guymer 2020-05-01 13:33:30 UTC
Hi,

I have just attempted to install "math/openblas" with the following configuration:

===> The following configuration options are available for openblas-0.3.7_3,1:
     AVX=on: Support Advanced Vector Extensions (AVX)
     AVX2=on: Support Advanced Vector Extensions 2 (AVX2)
     DYNAMIC_ARCH=off: Support multiple CPU types on i386 and amd64
     INTERFACE64=off: Use 8 byte integers on 64-bit architectures
     OPENMP=on: Use OpenMP for threading
===> Use 'make config' to modify these settings

... and I am pleased to report that it now compiles and installs successfully. Thank you very much for fixing it so that it can now compile with "OPENMP=on".

Cheers!
Comment 6 Igor Pavlov 2020-05-01 17:24:42 UTC
Upgrade of openblas-0.2.20_8,1 to openblas-0.3.7_3,1 was successful.
Thanks!