Bug 239588 - graphics/openshadinglanguage: Update to 1.10.6
Summary: graphics/openshadinglanguage: Update to 1.10.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords: needs-qa
: 239741 (view as bug list)
Depends on:
Blocks: 239736
  Show dependency treegraph
 
Reported: 2019-08-02 04:35 UTC by Shane
Modified: 2019-10-05 05:06 UTC (History)
2 users (show)

See Also:


Attachments
maintainer update for graphics/openshadinglanguage (1.16 KB, patch)
2019-08-02 04:35 UTC, Shane
FreeBSD: maintainer-approval+
Details | Diff
maintainer update for graphics/openshadinglanguage (2.11 KB, patch)
2019-08-14 02:42 UTC, Shane
FreeBSD: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Shane 2019-08-02 04:35:31 UTC
Created attachment 206214 [details]
maintainer update for graphics/openshadinglanguage

Update graphics/openshadinglanguage to v1.10.6
Comment 1 Shane 2019-08-14 02:42:24 UTC
Created attachment 206509 [details]
maintainer update for graphics/openshadinglanguage

includes llvm port renaming based on bug #239741
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2019-08-14 09:43:12 UTC
*** Bug 239741 has been marked as a duplicate of this bug. ***
Comment 3 commit-hook freebsd_committer 2019-09-02 22:41:10 UTC
A commit references this bug:

Author: swills
Date: Mon Sep  2 22:40:24 UTC 2019
New revision: 510863
URL: https://svnweb.freebsd.org/changeset/ports/510863

Log:
  graphics/openshadinglanguage: Update to 1.10.6

  PR:		239588
  Submitted by:	Shane <FreeBSD@ShaneWare.Biz> (maintainer)

Changes:
  head/graphics/openshadinglanguage/Makefile
  head/graphics/openshadinglanguage/distinfo
Comment 4 Steve Wills freebsd_committer 2019-09-02 22:41:32 UTC
Committed, thanks!
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2019-10-04 23:02:22 UTC
(In reply to Steve Wills from comment #4)

This commit did not actually commit v2 of the patch, which included my patch from bug #239741, which was obsoleted by this one.

May I have permission to commit that part?
Comment 6 Shane 2019-10-05 05:06:15 UTC
(In reply to Mark Linimon from comment #5)

I had noticed the LLVM change was missing. I have an update to 1.10.7 ready to submit, which will include the LLVM change as well as bump it to llvm80.


Actually I'll just submit it instead of talking about it - bug #241071