Bug 239639 - databases/postgresql-plruby: Unbreak build with PostgreSQL 11
Summary: databases/postgresql-plruby: Unbreak build with PostgreSQL 11
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Akinori MUSHA
URL:
Keywords: needs-qa, patch
Depends on:
Blocks: 239514
  Show dependency treegraph
 
Reported: 2019-08-04 04:54 UTC by Tobias Kortkamp
Modified: 2019-08-05 05:17 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (knu)


Attachments
postgresql-plruby.diff (10.29 KB, patch)
2019-08-04 04:54 UTC, Tobias Kortkamp
no flags Details | Diff
postgresql-plruby.diff (10.79 KB, patch)
2019-08-05 05:17 UTC, Tobias Kortkamp
tobik: maintainer-approval? (knu)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2019-08-04 04:54:57 UTC
Created attachment 206266 [details]
postgresql-plruby.diff

This is with DEFAULT_VERSIONS+=pgsql=11 in make.conf and blocks making it
the default.

============================================================
PostgreSQL 11.4
 is unsupported.  Try plruby-0.4.2.
============================================================
*** Error code 1

http://package18.nyi.freebsd.org/data/120amd64-default-PR239514/2019-07-29_20h41m52s/logs/postgresql-plruby-0.5.7_4.log

but there are also other issues.  The attached fixes the build with 11 but
I cannot speak for runtime.  Can you check?
Comment 1 Tobias Kortkamp freebsd_committer 2019-08-05 05:17:44 UTC
Created attachment 206287 [details]
postgresql-plruby.diff

- Also add DEPRECATED and EXPIRATION_DATE to the port since it seems to have
  been abandoned in 2010.