Bug 239664 - devel/py-botocore: Fix py-docutils dependency
Summary: devel/py-botocore: Fix py-docutils dependency
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Bradley T. Hughes
URL: https://people.FreeBSD.org/~sunpoet/p...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-05 17:15 UTC by Sunpoet Po-Chuan Hsieh
Modified: 2019-08-05 17:15 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (bhughes)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sunpoet Po-Chuan Hsieh freebsd_committer 2019-08-05 17:15:04 UTC
Fix py-docutils dependency

botocore banned docutils 0.15 (docutils != 0.15) for wrong python 2 wheel which
is already fixed [1][2]. And it does not affect FreeBSD ports users. Later,
botocore changed docutils from != 0.15 to < 0.15 [3]. This patch removes the
0.15 constraint. It also unbreaks textproc/py-elasticsearch-curator.

[1] https://github.com/aws/aws-cli/issues/4332
[2] https://sourceforge.net/p/docutils/bugs/365/
[3] https://github.com/boto/botocore/commit/add5c8b6b4e208fb0eaba49302df9c3d75b604b9