Bug 239733 - www/mod_php73 fails to build shared object libphp7.so
Summary: www/mod_php73 fails to build shared object libphp7.so
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Torsten Zuehlsdorff
Depends on:
Reported: 2019-08-09 06:38 UTC by sebastian
Modified: 2019-12-23 05:48 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description sebastian 2019-08-09 06:38:19 UTC
# uname -a    
FreeBSD waldfest 12.0-RELEASE-p3 FreeBSD 12.0-RELEASE-p3 GENERIC  amd64

I am trying to build mod_php73 7.3.8 from ports with default options:

/usr/ports/www/mod_php73]# make install


Looks fine but just before the end, it fails to install the shared object:

g/phpdbg_opcode.lo sapi/phpdbg/phpdbg_list.lo sapi/phpdbg/phpdbg_utils.lo sapi/phpdbg/phpdbg_info.lo sapi/phpdbg/phpdbg_cmd.lo sapi/phpdbg/phpdbg_set.lo sapi/phpdbg/phpdbg_frame.lo sapi/phpdbg/phpdbg_watch.lo sapi/phpdbg/phpdbg_btree.lo sapi/phpdbg/phpdbg_sigsafe.lo sapi/phpdbg/phpdbg_wait.lo sapi/phpdbg/phpdbg_io.lo sapi/phpdbg/phpdbg_eol.lo sapi/phpdbg/phpdbg_out.lo -lcrypt -largon2 -lcrypt -lm -lpthread -lxml2 -lz -llzma -lm -lpcre2-8 -lcrypt -largon2 -lcrypt    -o sapi/phpdbg/phpdbg
--- all ---

Build complete.
Don't forget to run 'make test'.
===>  Staging for mod_php73-7.3.8
===>   mod_php73-7.3.8 depends on file: /usr/local/sbin/apxs - found
===>   Generating temporary packing list
/bin/mkdir -p /usr/ports/www/mod_php73/work/stage/usr/local/libexec/apache24
install  -s -m 0644 /usr/ports/www/mod_php73/work/php-7.3.8/libs/libphp7.so  /usr/ports/www/mod_php73/work/stage/usr/local/libexec/apache24
install: /usr/ports/www/mod_php73/work/php-7.3.8/libs/libphp7.so: No such file or directory
*** Error code 71

This seems to me like a bug, so please take a look.
Comment 1 Torsten Zuehlsdorff freebsd_committer 2019-12-22 21:09:49 UTC
Hi Sebastian,

i'm sorry it took so long to respond to the issue. I tried to reproduce it several times, but always failed. I just tried it a minute ago and everything is fine.

Does this issue still persists for you? If yes, is there anything you changed? Did you set options for lang/php73, www/mod_php73 or www/apache24? What is the content of your /etc/make.conf?

Comment 2 sebastian 2019-12-23 05:48:57 UTC
Dear Thorsten,

many thanks for your response, much appreciated. I suppose this was a single issue on a machine, so I would propose to close the item.

Kind regards