Bug 239734 - java/openjdk11: Internal errors with JIRA
Summary: java/openjdk11: Internal errors with JIRA
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-java mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-09 08:51 UTC by Jonathan Chen
Modified: 2019-08-14 15:10 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (java)


Attachments
Run 1 failure (85.23 KB, text/plain)
2019-08-09 08:51 UTC, Jonathan Chen
no flags Details
Run 2 failure (85.21 KB, text/plain)
2019-08-09 08:51 UTC, Jonathan Chen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Chen 2019-08-09 08:51:10 UTC
Created attachment 206387 [details]
Run 1 failure

I've been successfully using openjdk8 with Atlassian's JIRA for the past few years, and today I decided to try using the openjdk11 with JIRA to see whether it would work (or even start up) at all.

Interestingly enough, startup progresses fine initially, but then fails with a SIGSEGV internal error. I've attached the logs from 2 startup attempts; if someone is interested in looking at it.
Comment 1 Jonathan Chen 2019-08-09 08:51:33 UTC
Created attachment 206388 [details]
Run 2 failure
Comment 2 Michael Osipov 2019-08-09 08:58:00 UTC
My first guess, Apache Felix is loading and misses a classes:

> Internal exceptions (10 events):
> Event: 28.507 Thread 0x000000083c1b1000 Exception <a 'java/lang/NoSuchMethodError'{0x000000101546f218}: 'void java.lang.invoke.DirectMethodHandle$Holder.invokeVirtual(java.lang.Object, java.lang.Object)'> (0x000000101546f218) thrown at [/construction/xports/java/openjdk11/work/openjdk-jdk11u-jd
> Event: 28.557 Thread 0x000000083c1b1000 Exception <a 'java/lang/NoSuchMethodError'{0x00000010151a1980}: 'long java.lang.invoke.DirectMethodHandle$Holder.invokeVirtual(java.lang.Object, java.lang.Object)'> (0x00000010151a1980) thrown at [/construction/xports/java/openjdk11/work/openjdk-jdk11u-jd
> Event: 28.673 Thread 0x000000083c1b1000 Exception <a 'java/io/FileNotFoundException'{0x0000001014aa04a0}> (0x0000001014aa04a0) thrown at [/construction/xports/java/openjdk11/work/openjdk-jdk11u-jdk-11.0.4-11-1/src/hotspot/share/prims/jni.cpp, line 615]
> Event: 28.673 Thread 0x000000083c1b1000 Exception <a 'java/io/FileNotFoundException'{0x0000001014aa1f18}> (0x0000001014aa1f18) thrown at [/construction/xports/java/openjdk11/work/openjdk-jdk11u-jdk-11.0.4-11-1/src/hotspot/share/prims/jni.cpp, line 615]
> Event: 29.825 Thread 0x000000083c1b1000 Exception <a 'java/lang/NoSuchMethodError'{0x000000100bd71198}: 'java.lang.Object java.lang.invoke.DirectMethodHandle$Holder.invokeVirtual(java.lang.Object, java.lang.Object, java.lang.Object, java.lang.Object)'> (0x000000100bd71198) thrown at [/construct
> Event: 29.943 Thread 0x000000083c1b1000 Exception <a 'java/lang/NoSuchMethodError'{0x0000001009d1eed8}: 'void java.lang.invoke.DirectMethodHandle$Holder.invokeSpecial(java.lang.Object, java.lang.Object, java.lang.Object, java.lang.Object, java.lang.Object)'> (0x0000001009d1eed8) thrown at [/con
> Event: 30.288 Thread 0x000000083c1b1000 Exception <a 'java/lang/NoSuchMethodError'{0x0000001017693dc0}: 'void java.lang.invoke.DirectMethodHandle$Holder.invokeStaticInit(java.lang.Object, java.lang.Object, java.lang.Object, java.lang.Object)'> (0x0000001017693dc0) thrown at [/construction/xport
> Event: 30.527 Thread 0x000000083c747800 Exception <a 'java/lang/NoSuchMethodError'{0x00000010161b3b68}: 'int java.lang.invoke.DirectMethodHandle$Holder.invokeStaticInit(java.lang.Object, java.lang.Object, java.lang.Object, java.lang.Object)'> (0x00000010161b3b68) thrown at [/construction/xports
> Event: 30.528 Thread 0x000000083c747800 Exception <a 'java/lang/IncompatibleClassChangeError'{0x00000010161bc790}: Found class java.lang.Object, but interface was expected> (0x00000010161bc790) thrown at [/construction/xports/java/openjdk11/work/openjdk-jdk11u-jdk-11.0.4-11-1/src/hotspot/share/
> Event: 32.901 Thread 0x000000083c747800 Exception <a 'java/io/FileNotFoundException'{0x0000001013969118}> (0x0000001013969118) thrown at [/construction/xports/java/openjdk11/work/openjdk-jdk11u-jdk-11.0.4-11-1/src/hotspot/share/prims/jni.cpp, line 615]

What about OpenJDK 12?
Comment 3 Greg Lewis freebsd_committer 2019-08-09 15:40:06 UTC
Thanks for the report.  Just so I can try to reproduce this, what version of Jira are you using?
Comment 4 Jonathan Chen 2019-08-09 22:16:53 UTC
This was on JIRA 8.2.3
Comment 5 Greg Lewis freebsd_committer 2019-08-12 18:45:45 UTC
I downloaded the current release (8.3.1) and was able to reproduce with that
Comment 6 Greg Lewis freebsd_committer 2019-08-12 18:53:56 UTC
To add some additional information, this is occurring for me on FreeBSD 11.3.  I can see from your failure logs that you are on 12.0, so it looks to be independent of FreeBSD version.
Comment 7 Greg Lewis freebsd_committer 2019-08-13 00:02:44 UTC
I built a debug build from my working branch and got it to start up correctly.  I'll try with a non-debug build.  If that works then I'll cut a release and update the port to see if that works for you.
Comment 8 Greg Lewis freebsd_committer 2019-08-13 05:04:11 UTC
I've updated the openjdk11 port, please give it go when you have a chance.
Comment 9 Jonathan Chen 2019-08-13 11:18:47 UTC
(In reply to Greg Lewis from comment #8)

Thanks for the update, Greg! JIRA 8.3.1 works with openjdk11-11.0.4+11.2.

Everything looks good with my testing so far.
Comment 10 Greg Lewis freebsd_committer 2019-08-13 13:13:50 UTC
Thanks for testing that!

I'll go ahead and close this then.
Comment 11 ari 2019-08-13 13:20:23 UTC
As another data point we have been running the new JDK build on a production Jira since about an hour after your commit. So about 10 hours now. Everything works well when previously it crashed within minutes.

FreeBSD 11.2-p7
Jira 8.3.0
Comment 12 Greg Lewis freebsd_committer 2019-08-14 15:10:02 UTC
Thanks!  That's a useful data point.