Bug 239757 - graphics/gegl: fix build with clang when using Altivec
Summary: graphics/gegl: fix build with clang when using Altivec
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-10 12:56 UTC by Piotr Kubaj
Modified: 2019-08-29 09:01 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
patch (886 bytes, patch)
2019-08-10 12:56 UTC, Piotr Kubaj
pkubaj: maintainer-approval? (gnome)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-08-10 12:56:22 UTC
Created attachment 206415 [details]
patch

Clang doesn't like including altivec.h manually:
/usr/lib/clang/8.0.1/include/altivec.h:69:19: error: unknown type name 'vector'
static __inline__ vector bool char __ATTRS_o_ai
                  ^
Comment 1 commit-hook freebsd_committer 2019-08-28 19:15:24 UTC
A commit references this bug:

Author: pkubaj
Date: Wed Aug 28 19:15:20 UTC 2019
New revision: 510090
URL: https://svnweb.freebsd.org/changeset/ports/510090

Log:
  graphics/gegl: fix build with clang when using Altivec

  Clang doesn't like including altivec.h manually:
  /usr/lib/clang/8.0.1/include/altivec.h:69:19: error: unknown type name 'vector'
  static inline vector bool char __ATTRS_o_ai

  PR:		239757
  Approved by:	linimon (mentor), gnome (maintainer timeout)
  Differential Revision:	https://reviews.freebsd.org/D21404

Changes:
  head/graphics/gegl/Makefile
Comment 2 Ting-Wei Lan 2019-08-29 09:01:35 UTC
(In reply to Piotr Kubaj from comment #0)
Does it imply that devel/opencl port needs the same modification as well? opencl port also includes a copy of cl_platform.h file, but I can't test it because I don't know how to reproduce the error.