Bug 239760 - www/falkon: New tab immediately goes to the URI qupzilla:speeddial and complains that it failed to open it
Summary: www/falkon: New tab immediately goes to the URI qupzilla:speeddial and compla...
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-10 17:33 UTC by Yuri Victorovich
Modified: 2019-10-17 14:32 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2019-08-10 17:33:46 UTC
Other URLs don't work:
> No internet
> There is something wrong with the proxy server, or the address is incorrect.
> Try:
> Contacting the system admin
> Checking the proxy address
> ERR_PROXY_CONNECTION_FAILED

I use xfce4 desktop environment.
Is some dependency missing that is always present in kde?
Comment 1 Lorenzo Salvadore 2019-08-11 09:13:46 UTC
I'm a falkon user and I cannot reproduce your issue: opening a new tab with speeddial works for me.
However, I see that you report the URI qupzilla:speeddial. This URI does not work for me either, but falkon:speeddial does. This makes me suspect that you are an old qupzilla user now using falkon: try removing your old qupzilla configuration (or manually fix it) and see if this fixes your problem.

Moreover, you can change the default action for new tabs in falkon's preferences, if you wish (I prefer opening a blank page).

I use falkon 3.1.10 compiled from ports with all options off.
Comment 2 Yuri Victorovich freebsd_committer 2019-08-11 10:08:31 UTC
(In reply to Lorenzo Salvadore from comment #1)

After upgrading the system I still see the problem.
falkon-3.1.0 from the package.
Comment 3 Lorenzo Salvadore 2019-08-11 11:39:28 UTC
(In reply to Yuri Victorovich from comment #2)

Sorry, I have wrongly typed my version number: it is 3.1.0 for me too.

Does falkon:speeddial works for you?
I think it could be helpful if you provide the content of the page falkon:config.
Comment 4 Lorenzo Salvadore 2019-08-11 11:40:31 UTC
PS: be careful not to include sensitive information such as passwords in your provided falkon:config.
Comment 5 Adriaan de Groot freebsd_committer 2019-08-11 14:09:37 UTC
Specifically for speeddial: you might want to check Falkon -> Preferences -> General to confirm that the "On new tab" setting is falkon:speeddial. If in doubt, switch to "open other page" and look at the specific URL that there is.

Yuri, your comment #1 doesn't match the title of the PR -- please clarify.
Comment 6 Yuri Victorovich freebsd_committer 2019-08-11 17:14:33 UTC
(In reply to Adriaan de Groot from comment #5)

There are 2 problems:
1. New tab always goes to qupzilla
2. When some valid URL is typed in it fails to connect saying that there is no Internet. I think that it is trying to use some proxy, but I am not sure where is it taking from.


Yuri
Comment 7 Adriaan de Groot freebsd_committer 2019-10-08 10:48:29 UTC
Within Falkon, use the standard keybinding ctrl-shift-, (comma) to get the preferences dialog, or use the mouse:

Hamburger menu (upper-right) -> Preferences

In the *general* page, check the setting for new tab. Switch to *open other page* and check the url listed there: it should be `falkon:speeddial`. If not, change the url. You can try to set that drop-down to *open speed dial* or another setting to double-check.

In the *browsing* page, pick the *proxy configuration* tab and check the settings there. I don't know if the default "system proxy configuration" works in desktop environments like xfce; try *no proxy*.
Comment 8 Adriaan de Groot freebsd_committer 2019-10-17 14:32:12 UTC
Can't reproduce; it looks to me like a configuration error which needs to be chased by the OP.