Bug 239769 - databases/rrdtool perl binding core dump on arm64 (RPI3)
Summary: databases/rrdtool perl binding core dump on arm64 (RPI3)
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Some People
Assignee: Rodrigo Osorio
URL:
Keywords: crash
Depends on:
Blocks:
 
Reported: 2019-08-10 23:52 UTC by Rodrigo Osorio
Modified: 2019-08-23 11:54 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (zeising)


Attachments
Sample script to reproduce the issue (860 bytes, application/x-shellscript)
2019-08-10 23:52 UTC, Rodrigo Osorio
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Osorio freebsd_committer 2019-08-10 23:52:46 UTC
Created attachment 206432 [details]
Sample script to reproduce the issue

The rrdtools perl bindings, and more specifically the  RRDs::graph
call on arm64 architectures, causes a segmentation fault.

See in attachments, a sample code who reproduces the error. As said, the
issue is not present in amd64 and i386 installs, only arm64 fails.

I tried to use the rrdtool command line (rrdtool graphic), and had no crash,
so the issue only appears when calling through the perl bindings.

You can find the core dump here: http://files.osorio.me/pr-rrd/perl.core.xz
and the ktrace result http://files.osorio.me/pr-rrd/ktrace.out (ktrace -i sh test-script.sh).

Running perl in debug mode (-D) doesn't give more infos.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-11 02:54:59 UTC
@Rodrigo, If you could attach the dumps/trace (compressed if required), that'd be great, as external URL references tend to go stale/missing over time, as is having all information self-contained in issues for our future selves.
Comment 2 mikael.urankar 2019-08-11 09:52:08 UTC
What version do you use? If it's 11.x or 12.0 you'll have to update to a newer version, there is a bug in rtld in these versions.
I don't have the problem on my system (13-current)
Comment 3 Rodrigo Osorio freebsd_committer 2019-08-11 10:03:19 UTC
(In reply to mikael.urankar from comment #2)

@mikael.urankar@gmail.com : thanks, good to know. I gonna try it.
Comment 4 Rodrigo Osorio freebsd_committer 2019-08-11 10:05:02 UTC
(In reply to mikael.urankar from comment #2)

I'm using the 12.0-RELEASE.
Comment 5 Rodrigo Osorio freebsd_committer 2019-08-11 13:55:18 UTC
As reported by mikael.urankar, the issue was in rtls. It was solved on 13.0-CURRENT and latest 12.0-STABLE.

We can close the issue.
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-23 03:15:13 UTC
^Triage: Clarify/set slightly better Resolution as crashes are almost always not intended behaviour.

The issue 'was' a bug, but was FIXED by a base bug fix (would be great to have base bug/commit references in this issue for where/when it was fixed), so overcome by events is more appropriate given the timeline of this issue.
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-23 03:15:51 UTC
^Triage: Assign to committer that resolved
Comment 8 mikael.urankar 2019-08-23 11:54:50 UTC
fixed in base r342113