Bug 239785 - lang/rust-nightly: invalid version 3 on git_proxy_options; class=Invalid (3)
Summary: lang/rust-nightly: invalid version 3 on git_proxy_options; class=Invalid (3)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: FreeBSD Rust Team
URL: https://github.com/rust-lang/rust/iss...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-11 22:35 UTC by Yuri Victorovich
Modified: 2019-08-17 21:29 UTC (History)
2 users (show)

See Also:
tobik: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2019-08-11 22:35:03 UTC
On FreeBSD 12 amd64 rust-nightly-1.38.0.20190811_1 fails:

$ cargo build
    Updating crates.io index
error: failed to load source for a dependency on `image`

Caused by:
  Unable to update registry `https://github.com/rust-lang/crates.io-index`

Caused by:
  failed to fetch `https://github.com/rust-lang/crates.io-index`

Caused by:
  invalid version 3 on git_proxy_options; class=Invalid (3)

Project: https://github.com/Twinklebear/bspline
Comment 1 Tobias Kortkamp freebsd_committer 2019-08-12 08:43:46 UTC
Confirmed.
Comment 2 commit-hook freebsd_committer 2019-08-17 21:04:58 UTC
A commit references this bug:

Author: jbeich
Date: Sat Aug 17 21:04:21 UTC 2019
New revision: 509173
URL: https://svnweb.freebsd.org/changeset/ports/509173

Log:
  lang/rust-nightly: unbreak cargo git fetch after r507928

  libgit2-sys 0.8.2 switched to libgit2 0.29 API without bumping minor
  version and adjusting pkg-config check. devel/libgit2 is still at
  0.28, so FFI silently fails with a confusing error e.g.,

    invalid version 3 on git_proxy_options; class=Invalid (3)

  USES=cargo consumers are affected but none use libgit2-sys 0.8.2 yet.

  PR:		239785
  Reported by:	yuri

Changes:
  head/lang/rust-nightly/Makefile
  head/lang/rust-nightly/files/patch-vendor_libgit2-sys_lib.rs