Bug 239792 - devel/scons: Update to 3.1.1 and relax python version
Summary: devel/scons: Update to 3.1.1 and relax python version
Status: Closed DUPLICATE of bug 237122
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL: https://scons.org/tag/releases.html
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2019-08-12 02:05 UTC by Terry Kennedy
Modified: 2019-08-14 15:06 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments
Patch to scons Makefile for new upstream version (793 bytes, text/plain)
2019-08-12 02:05 UTC, Terry Kennedy
no flags Details
Patch re-done as unified diff (483 bytes, patch)
2019-08-12 02:35 UTC, Terry Kennedy
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Terry Kennedy 2019-08-12 02:05:38 UTC
Created attachment 206459 [details]
Patch to scons Makefile for new upstream version

This patch updates the scons port to 3.1.1 which is the latest version according to https://scons.org/tag/releases.html

This may be a duplicate or related to PR's 327122 and 226401 as the upstream 3.1.1 builds fine with Python 3.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-12 02:12:10 UTC
Thank you for the report and patch Terry. Could you update the attachment to be in the form of a unified diff please (svn diff or diff -u)

@Sunpoet I'd also recommend splitting out the relax Python version restriction, as SCons has supported 2 and 3 since 3.0.1 (and earlier), so that that change can be MFH'd

"This release supports Python versions 2.7.* as well as 3.5+."

This update actually supersedes bug 237122 (update to 3.0.5)

I'll leave it up to the maintainer to determine whether this will stay open, and to deal with the update to 3.1.1 after bug 237122 is closed, or whether they will update bug 237122 to 3.1.1 and close this issue as a duplicate of it
Comment 2 Terry Kennedy 2019-08-12 02:35:39 UTC
Created attachment 206460 [details]
Patch re-done as unified diff

Here's the unified diff version. Also, sorry about mis-remembering bug 237122 as bug 327122. We're a long way off from another 90,000 bug reports, hopefully. 8-}
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-08-13 21:03:08 UTC
(In reply to Terry Kennedy from comment #0)

The scons update itself is not a problem. The real problem is to relax USES=python after the default version changed from 2.7 to 3.6. Most of its consumers are not ready for Python 3.

(In reply to Kubilay Kocak from comment #1)

I would rather follow up bug #237122 as the patch here is incomplete.
Comment 4 Terry Kennedy 2019-08-14 04:07:33 UTC
(In reply to Sunpoet Po-Chuan Hsieh from comment #3)
Yes, I think the change to a Python 3 default was a little premature.

What is incomplete about this patch? I have used it (patch < thisfile; make makesum; make) on several systems.
Comment 5 Antoine Brodin freebsd_committer 2019-08-14 09:10:37 UTC

*** This bug has been marked as a duplicate of bug 237122 ***
Comment 6 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-08-14 14:36:18 UTC
(In reply to Terry Kennedy from comment #4)

Sorry, I did not say it clearly.
The scons patch itself is fine.
Unfortunately, the complete patch should contain fixes for more than half of its dependent ports which still stay with python 2 because scons would use python 3.x by default (USES=python).
Comment 7 Terry Kennedy 2019-08-14 15:06:11 UTC
(In reply to Sunpoet Po-Chuan Hsieh from comment #6)
Now I understand. I only have a small number of ports on my test system and I had previously checked for "USES= python:2.7" among them, and the only ports that had that did not depend on scons.