Bug 239829 - multimedia/ffmpeg: build with MYSOFA=on fails
Summary: multimedia/ffmpeg: build with MYSOFA=on fails
Status: Closed DUPLICATE of bug 239828
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-multimedia mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-13 20:21 UTC by Jack
Modified: 2019-08-13 20:23 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (multimedia)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jack 2019-08-13 20:21:53 UTC
When MYSOFA is enabled, build fails with following:

cc -I. -I./ -DLIBICONV_PLUG -isystem /usr/local/include -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DPIC -DZLIB_CONST -DHAVE_AV_CONFIG_H -DBUILDING_avfilter -O2 -pipe -march=ivybridge  -DLIBICONV_PLUG -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing    -std=c11 -fomit-frame-pointer -fPIC -pthread  -I/usr/local/include -I/usr/local/include/p11-kit-1 -I/usr/local/include -I/usr/local/include/lilv-0 -I/usr/local/include -I/usr/local/include/serd-0 -I/usr/local/include/sord-0 -I/usr/local/include/sratom-0 -I/usr/local/include -I/usr/local/include/harfbuzz -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/freetype2 -I/usr/local/include/libpng16 -I/usr/local/include/fribidi -I/usr/local/include -I/usr/local/include/libxml2 -I/usr/local/include/freetype2 -I/usr/local/include/libpng16 -I/usr/local/include/bs2b -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include/libdrm -I/usr/local/include -I/usr/local/include -I/usr/local/include/freetype2 -I/usr/local/include/libpng16 -I/usr/local/include/freetype2 -I/usr/local/include/libpng16 -I/usr/local/include/fribidi -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include/lensfun -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include -I/usr/local/include -I/usr/local/include/openjpeg-2.3 -I/usr/local/include -I/usr/local/include/opus -I/usr/local/include/opus -I/usr/local/include -D_REENTRANT -I/usr/local/include/librsvg-2.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include -I/usr/local/include/gdk-pixbuf-2.0 -I/usr/local/include/cairo -I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 -I/usr/local/include/libpng16 -I/usr/local/include/libdrm -D_THREAD_SAFE -pthread -I/usr/local/include -I/usr/local/include/samba4 -I/usr/local/include -I/usr/local/include -I/usr/local/include/svt-hevc -I/usr/local/include -I/usr/local/include/leptonica -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include/pgm-5.2 -I/usr/local/include -I/usr/local/include/libxml2 -I/usr/local/include -I/usr/local/include/vapoursynth -I/usr/local/include -I/usr/local/include/python3.6m -I/usr/local/include -I/usr/local/include/alsa -I/usr/local/include -I/usr/local/include -I/usr/local/include -pthread -I/usr/local/include -pthread -I/usr/local/include -pthread -I/usr/local/include -pthread -I/usr/local/include -I/usr/local/include -I/usr/local/include -Wdeclaration-after-statement -Wall -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -Wno-pointer-to-int-cast -Wstrict-prototypes -Wempty-body -Wno-parentheses -Wno-switch -Wno-format-zero-length -Wno-pointer-sign -Wno-unused-const-variable -Wno-char-subscripts -O3 -fno-math-errno -fno-signed-zeros -mstack-alignment=16 -Qunused-arguments -Werror=implicit-function-declaration -Werror=missing-prototypes -Werror=return-type -I/usr/local/include/SDL2 -I/usr/local/include -D_REENTRANT -D_THREAD_SAFE  -MMD -MF libavfilter/af_superequalizer.d -MT libavfilter/af_superequalizer.o -c -o libavfilter/af_superequalizer.o libavfilter/af_superequalizer.c
cc -I. -I./ -DLIBICONV_PLUG -isystem /usr/local/include -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DPIC -DZLIB_CONST -DHAVE_AV_CONFIG_H -DBUILDING_avfilter -O2 -pipe -march=ivybridge  -DLIBICONV_PLUG -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing    -std=c11 -fomit-frame-pointer -fPIC -pthread  -I/usr/local/include -I/usr/local/include/p11-kit-1 -I/usr/local/include -I/usr/local/include/lilv-0 -I/usr/local/include -I/usr/local/include/serd-0 -I/usr/local/include/sord-0 -I/usr/local/include/sratom-0 -I/usr/local/include -I/usr/local/include/harfbuzz -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/freetype2 -I/usr/local/include/libpng16 -I/usr/local/include/fribidi -I/usr/local/include -I/usr/local/include/libxml2 -I/usr/local/include/freetype2 -I/usr/local/include/libpng16 -I/usr/local/include/bs2b -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include/libdrm -I/usr/local/include -I/usr/local/include -I/usr/local/include/freetype2 -I/usr/local/include/libpng16 -I/usr/local/include/freetype2 -I/usr/local/include/libpng16 -I/usr/local/include/fribidi -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include/lensfun -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include -I/usr/local/include -I/usr/local/include/openjpeg-2.3 -I/usr/local/include -I/usr/local/include/opus -I/usr/local/include/opus -I/usr/local/include -D_REENTRANT -I/usr/local/include/librsvg-2.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include -I/usr/local/include/gdk-pixbuf-2.0 -I/usr/local/include/cairo -I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 -I/usr/local/include/libpng16 -I/usr/local/include/libdrm -D_THREAD_SAFE -pthread -I/usr/local/include -I/usr/local/include/samba4 -I/usr/local/include -I/usr/local/include -I/usr/local/include/svt-hevc -I/usr/local/include -I/usr/local/include/leptonica -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include/pgm-5.2 -I/usr/local/include -I/usr/local/include/libxml2 -I/usr/local/include -I/usr/local/include/vapoursynth -I/usr/local/include -I/usr/local/include/python3.6m -I/usr/local/include -I/usr/local/include/alsa -I/usr/local/include -I/usr/local/include -I/usr/local/include -pthread -I/usr/local/include -pthread -I/usr/local/include -pthread -I/usr/local/include -pthread -I/usr/local/include -I/usr/local/include -I/usr/local/include -Wdeclaration-after-statement -Wall -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -Wno-pointer-to-int-cast -Wstrict-prototypes -Wempty-body -Wno-parentheses -Wno-switch -Wno-format-zero-length -Wno-pointer-sign -Wno-unused-const-variable -Wno-char-subscripts -O3 -fno-math-errno -fno-signed-zeros -mstack-alignment=16 -Qunused-arguments -Werror=implicit-function-declaration -Werror=missing-prototypes -Werror=return-type -I/usr/local/include/SDL2 -I/usr/local/include -D_REENTRANT -D_THREAD_SAFE  -MMD -MF libavfilter/af_surround.d -MT libavfilter/af_surround.o -c -o libavfilter/af_surround.o libavfilter/af_surround.c
libavfilter/af_sofalizer.c:166:32: error: implicit declaration of function 'mysofa_neighborhood_init_withstepdefine' is
      invalid in C99 [-Werror,-Wimplicit-function-declaration]
        s->sofa.neighborhood = mysofa_neighborhood_init_withstepdefine(s->sofa.hrtf,
                               ^
libavfilter/af_sofalizer.c:166:32: warning: this function declaration is not a prototype [-Wstrict-prototypes]
libavfilter/af_sofalizer.c:166:30: warning: incompatible integer to pointer conversion assigning to
      'struct MYSOFA_NEIGHBORHOOD *' from 'int' [-Wint-conversion]
        s->sofa.neighborhood = mysofa_neighborhood_init_withstepdefine(s->sofa.hrtf,
                             ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2 warnings and 1 error generated.
gmake[2]: *** [ffbuild/common.mak:59: libavfilter/af_sofalizer.o] Error 1
gmake[2]: *** Waiting for unfinished jobs....
gmake[2]: Leaving directory '/usr/obj/usr/ports/multimedia/ffmpeg/work/ffmpeg-4.2'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/multimedia/ffmpeg
*** Error code 1

Stop.
make: stopped in /usr/ports/multimedia/ffmpeg
Comment 1 Jack 2019-08-13 20:23:39 UTC

*** This bug has been marked as a duplicate of bug 239828 ***