Bug 239852 - /usr/ports/x11/xorg error: "python poisoning" - needs Python 3.6 at least, but 2.7 was specified
Summary: /usr/ports/x11/xorg error: "python poisoning" - needs Python 3.6 at least, bu...
Status: Closed DUPLICATE of bug 233723
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-14 13:13 UTC by Adam Heinrich
Modified: 2019-08-14 13:47 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Heinrich 2019-08-14 13:13:12 UTC
after 
cd /usr/ports/x11/xorg

and

make install clean

I receive :

====> Compressing man pages (compress-man)
===>  Installing for bison-3.4.1,1
===>  Checking if bison is already installed
===>   Registering installation for bison-3.4.1,1 as automatic
Installing bison-3.4.1,1...
===>   mesa-dri-18.3.2_4 depends on executable: bison - found
===>   Returning to build of mesa-dri-18.3.2_4
===>   mesa-dri-18.3.2_4 depends on executable: msgfmt - found
===>   mesa-dri-18.3.2_4 depends on executable: gmake - found
===>   mesa-dri-18.3.2_4 depends on package: pkgconf>=1.3.0_1 - found
===>   mesa-dri-18.3.2_4 depends on file: /usr/local/bin/python2.7 - found
===>   mesa-dri-18.3.2_4 depends on package: llvm80>=3.9.0_4 - not found
===>  llvm80-8.0.1_2 needs Python 3.6 at least, but 2.7 was specified.
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/devel/llvm80
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/graphics/mesa-dri
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/graphics/mesa-dri
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/x11/xorg
*** Error code 1

Stop.
make: stopped in /usr/ports/x11/xorg
Comment 1 Jan Beich freebsd_committer 2019-08-14 13:18:53 UTC
See bug 233723.
Comment 2 Niclas Zeising freebsd_committer 2019-08-14 13:19:44 UTC
That looks like a problem with the llvm80 package, not mesa-dri.
Do you have any nondefault options?
Comment 3 Walter Schwarzenfeld freebsd_triage 2019-08-14 13:47:11 UTC

*** This bug has been marked as a duplicate of bug 233723 ***