Bug 239929 - [NEW PORT] audio/fossmixer: Graphical mixer application for OSS
Summary: [NEW PORT] audio/fossmixer: Graphical mixer application for OSS
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rodrigo Osorio
URL:
Keywords: feature, needs-qa
Depends on:
Blocks:
 
Reported: 2019-08-17 20:25 UTC by manwe
Modified: 2019-08-20 12:35 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (manwe)


Attachments
fossmixer files (4.51 KB, text/plain)
2019-08-17 20:25 UTC, manwe
no flags Details
shar with fixes (4.54 KB, text/plain)
2019-08-19 21:20 UTC, Rodrigo Osorio
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description manwe 2019-08-17 20:25:14 UTC
Created attachment 206642 [details]
fossmixer files

FOSS Mixer is a graphical mixer application for FreeBSD to control OSS
audio backend. Mixer can be use to control audio levels, set recording
source, and it includes white noise generator for testing the audio
output. It is pretty much what mixer(1) does. FOSS Mixer does not need
third party user interface library, it runs on plain X11/OpenGL.

WWW: http://detroit.sourceforge.net/app_fossmixer.html
Comment 1 Rodrigo Osorio freebsd_committer 2019-08-19 21:20:49 UTC
Created attachment 206710 [details]
shar with fixes

Hi,

Building dependencies are missing in your port.
Find attached an updated version, please try it,
ant let me know if the port work as intended.

Regards,
-- rodrigo
Comment 2 manwe 2019-08-20 11:58:55 UTC
(In reply to Rodrigo Osorio from comment #1)
Yes, tested the patch and everything works as intended. Thanks.
Comment 3 commit-hook freebsd_committer 2019-08-20 12:34:36 UTC
A commit references this bug:

Author: rodrigo
Date: Tue Aug 20 12:33:46 UTC 2019
New revision: 509424
URL: https://svnweb.freebsd.org/changeset/ports/509424

Log:
  New port audio/fossmixer: Graphical mixer application for OSS

  FOSS Mixer is a graphical mixer application for FreeBSD to control OSS
  audio backend. Mixer can be use to control audio levels, set recording
  source, and it includes white noise generator for testing the audio
  output. It is pretty much what mixer(1) does. FOSS Mixer does not need
  third party user interface library, it runs on plain X11/OpenGL.

  PR:		239929
  Submitted by:	manwe@suomi24.fi

Changes:
  head/audio/Makefile
  head/audio/fossmixer/
  head/audio/fossmixer/Makefile
  head/audio/fossmixer/distinfo
  head/audio/fossmixer/pkg-descr
  head/audio/fossmixer/pkg-plist
Comment 4 Rodrigo Osorio freebsd_committer 2019-08-20 12:35:14 UTC
Committed with small changes, thanks