Bug 239947 - multimedia/kdenlive: version number went backwards again
Summary: multimedia/kdenlive: version number went backwards again
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-kde (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-18 17:35 UTC by Ting-Wei Lan
Modified: 2019-08-18 19:49 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ting-Wei Lan 2019-08-18 17:35:14 UTC
The version number of kdenlive was 18.12.3_4, but it became 18.12.3 after r509000. Therefore, 'pkg version' command reported the package as 'succeeds index' after updating the ports tree on the system, which is unexpected.
Comment 1 commit-hook freebsd_committer 2019-08-18 19:09:44 UTC
A commit references this bug:

Author: adridg
Date: Sun Aug 18 19:09:05 UTC 2019
New revision: 509237
URL: https://svnweb.freebsd.org/changeset/ports/509237

Log:
  Restore PORTREVISION to multimedia/kdenlive

  This is basically a duplicate of

     r503971 | tcberner | 2019-06-11 19:14:05 +0200 (Tue, 11 Jun 2019) | 8 lines
     M /head/multimedia/kdenlive/Makefile

     In r503611 the PORTREVISION was mistakenly dropped (kdenlive is at the
     moment held back at a lower version).

  PR:		239947
  Reported by:	Ting-Wei Lan

Changes:
  head/multimedia/kdenlive/Makefile
Comment 2 Adriaan de Groot freebsd_committer 2019-08-18 19:49:47 UTC
Thanks for reporting (again). This time I've addewd a note to the port Makefile, so hopefully we'll not break it **again** on update. That said, kdenlive is now 18.12 while we have KDE Applications 19.08, so it's more than due for a real update.