Bug 239950 - graphics/digikam poudriere build fails on 12-stable amd64
Summary: graphics/digikam poudriere build fails on 12-stable amd64
Status: In Progress
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-18 18:35 UTC by Robert Cina
Modified: 2019-09-15 00:32 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cina 2019-08-18 18:35:32 UTC
The graphics/digikam port fails to build on my 12-stable amd 64 system.  There are numerous use of undeclared identifier errors.  The first error is the use of undeclared identifier 'KCalCore' 

Below is an excerpt of the poudriere build log of the errors present:

/wrkdirs/usr/ports/graphics/digikam/work/digikam-6.0.0/core/utilities/assistants/calendar/print/calsettings.cpp:299:5: error: use of undeclared identifier 'KCalCore'
    KCalCore::MemoryCalendar::Ptr memCal(new KCalCore::MemoryCalendar(QTimeZone::utc()));
    ^
/wrkdirs/usr/ports/graphics/digikam/work/digikam-6.0.0/core/utilities/assistants/calendar/print/calsettings.cpp:305:5: error: use of undeclared identifier 'KCalCore'
    KCalCore::FileStorage::Ptr fileStorage(new KCalCore::FileStorage(memCal, url.toLocalFile(), new KCalCore::ICalFormat));
    ^
/wrkdirs/usr/ports/graphics/digikam/work/digikam-6.0.0/core/utilities/assistants/calendar/print/calsettings.cpp:309:10: error: use of undeclared identifier 'fileStorage'
    if (!fileStorage->load())
         ^
/wrkdirs/usr/ports/graphics/digikam/work/digikam-6.0.0/core/utilities/assistants/calendar/print/calsettings.cpp:327:9: error: use of undeclared identifier 'KCalCore'
        KCalCore::Event::List list = memCal->rawEvents(qFirst, qLast);
        ^
/wrkdirs/usr/ports/graphics/digikam/work/digikam-6.0.0/core/utilities/assistants/calendar/print/calsettings.cpp:327:31: error: use of undeclared identifier 'list'; did you mean 'std::list'?
        KCalCore::Event::List list = memCal->rawEvents(qFirst, qLast);
                              ^~~~
                              std::list
/usr/include/c++/v1/list:834:28: note: 'std::list' declared here
class _LIBCPP_TEMPLATE_VIS list
                           ^
/wrkdirs/usr/ports/graphics/digikam/work/digikam-6.0.0/core/utilities/assistants/calendar/print/calsettings.cpp:327:38: error: use of undeclared identifier 'memCal'
        KCalCore::Event::List list = memCal->rawEvents(qFirst, qLast);
                                     ^
/wrkdirs/usr/ports/graphics/digikam/work/digikam-6.0.0/core/utilities/assistants/calendar/print/calsettings.cpp:329:23: error: use of undeclared identifier 'KCalCore'
        foreach(const KCalCore::Event::Ptr event, list)
                      ^
/usr/local/include/qt5/QtCore/qglobal.h:1029:21: note: expanded from macro 'foreach'
#    define foreach Q_FOREACH
                    ^
/wrkdirs/usr/ports/graphics/digikam/work/digikam-6.0.0/core/utilities/assistants/calendar/print/calsettings.cpp:336:17: error: use of undeclared identifier 'KCalCore'
                KCalCore::Recurrence* const recur = event->recurrence();
                ^
/wrkdirs/usr/ports/graphics/digikam/work/digikam-6.0.0/core/utilities/assistants/calendar/print/calsettings.cpp:352:9: error: use of undeclared identifier 'memCal'
        memCal->close();
        ^
/wrkdirs/usr/ports/graphics/digikam/work/digikam-6.0.0/core/utilities/assistants/calendar/print/calsettings.cpp:353:9: error: use of undeclared identifier 'fileStorage'
        fileStorage->close();
        ^
10 errors generated.
Comment 1 Adriaan de Groot freebsd_committer 2019-08-18 21:47:50 UTC
You're right, the KDE-PIM libraries changed (in particular, changed **name**) since digikam 6.0 came out. I don't know why that didn't come out in exp-runs beforehand.

There is a digikam 6.2 release -- we've been lagging in that regard -- which might work; i'll look into updating the port this week.
Comment 2 commit-hook freebsd_committer 2019-08-31 11:20:14 UTC
A commit references this bug:

Author: adridg
Date: Sat Aug 31 11:19:26 UTC 2019
New revision: 510364
URL: https://svnweb.freebsd.org/changeset/ports/510364

Log:
  Update graphics/digikam to latest upstream release, 6.2.0

  This version (a) builds with current KDE Frameworks (b) doesn't
  need kipiplugins, because upstream moved away from them and
  we just moved/renamed them anyway.

  PR:		239950
  Reported by:	pkg-fallout. Robert Cina

Changes:
  head/graphics/digikam/Makefile
  head/graphics/digikam/distinfo
  head/graphics/digikam/files/patch-CMakeLists.txt
  head/graphics/digikam/files/patch-core_CMakeLists.txt
  head/graphics/digikam/files/patch-doc-translated_CMakeLists.txt
  head/graphics/digikam/pkg-plist
Comment 3 Ulrich Spoerlein freebsd_committer 2019-09-06 13:20:01 UTC
Thanks, it now builds fine, but then segfaults immediately upon startup.

% digikam
digikam.widgets: Use installed icons
[1]    74825 segmentation fault  digikam


ktrace shows this:

 53682 digikam  PSIG  SIGSEGV SIG_DFL code=SEGV_MAPERR
 53682 digikam  RET   poll -1 errno 4 Interrupted system call
 53682 digikam:disk$0 RET   _umtx_op -1 errno 4 Interrupted system call
 53682 digikam  NAMI  "digikam.core"
Comment 4 Oleg Shelomov 2019-09-14 17:54:36 UTC
I used poudriere for the package. After package installation digikam-6.3.0 doesn't start:
~ % digikam
digikam.widgets: Use installed icons
[1]    1027 bus error  digikam

FreeBSD 11.2-RELEASE-p14 FreeBSD 11.2-RELEASE-p14 #0: Mon Aug 19 22:38:50 UTC 2019     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
Comment 5 graham 2019-09-15 00:32:37 UTC
(In reply to Oleg Shelomov from comment #4)
This crash is almost certainly a dup of https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=240466