Bug 240071 - print/harfbuzz-hb-view: fails to generate index with Synth
Summary: print/harfbuzz-hb-view: fails to generate index with Synth
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Koop Mast
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-08-24 12:58 UTC by Dries Michiels
Modified: 2019-08-25 04:14 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dries Michiels 2019-08-24 12:58:08 UTC
After updating the ports tree to r509722 (including latest commit to the port in question), synth fails to build index on my system.

[/usr/home/dries]$ sudo synth just-build /root/portlist
Regenerating flavor index: this may take a while ...
Scanning entire ports tree.
 progress: 66.58%
culprit: print/harfbuzz-hb-view
  Scan aborted because 'make' encounted an error in the Makefile.
  print/harfbuzz-hb-view (return code = 1)
Flavor index generation failed: ports scan


CC: Latest committer.
Comment 1 Roman Serbski 2019-08-24 13:42:10 UTC
+1

There is a typo in revision 509716 (https://svnweb.freebsd.org/ports?view=revision&revision=509716):

harfbuzz-bh-view should be replaced with harfbuzz-hb-view

Cheers.
Comment 2 commit-hook freebsd_committer 2019-08-24 20:38:12 UTC
A commit references this bug:

Author: kwm
Date: Sat Aug 24 20:37:19 UTC 2019
New revision: 509754
URL: https://svnweb.freebsd.org/changeset/ports/509754

Log:
  Fix typo in port directory name.

  PR:		240071 [1]
  Reported by:	jbeich@, Dries Michiels <driesm.michiels@gmail.com> [1]

Changes:
  head/print/harfbuzz-bh-view/
  head/print/harfbuzz-hb-view/
Comment 3 Koop Mast freebsd_committer 2019-08-24 20:40:39 UTC
thanks for reporting.