Bug 240108 - emulators/virtualbox-ose: 5.2.32_1 fails to link rdesktop-vrdp: undefined symbol: SSL|BN|HMAC_*
Summary: emulators/virtualbox-ose: 5.2.32_1 fails to link rdesktop-vrdp: undefined sym...
Status: Closed DUPLICATE of bug 232969
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Kubilay Kocak
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2019-08-25 19:50 UTC by Martin Filla
Modified: 2019-08-26 04:50 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments
configure.log (14.23 KB, text/plain)
2019-08-25 19:50 UTC, Martin Filla
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Filla 2019-08-25 19:50:23 UTC
Created attachment 206903 [details]
configure.log

Hello, i have problem with compilation virtualbox-ose with portmaster
this is logs


uname -a
FreeBSD  12.0-RELEASE-p10 FreeBSD 12.0-RELEASE-p10 GENERIC  amd64

kBuild: Linking RTLs
14 warnings generated.
kBuild: Linking RTRm
kBuild: Linking RTManifest
kBuild: Linking RTLdrFlt
kBuild: Linking RTGzip
kBuild: Linking RTHttp
kBuild: Linking RTMkDir
kBuild: Linking RTRmDir
kBuild: Linking RTShutdown
kBuild: Linking RTTar
kBuild: Linking RTUnzip
kBuild: Linking RTDbgSymCache
kBuild: Linking RTSignTool
kBuild: Linking RTTraceLogTool
kBuild: Installing VBoxCpuReport => /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/bin/VBoxCpuReport
kBuild: Linking tstAsmStructs
kBuild: Installing tstAsmStructsRC => /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/bin/tstAsmStructsRC
kBuild: Linking tstGlobalConfig
kBuild: Linking tstSSM-2
kBuild: Linking SUPInstall
kBuild: Linking SUPUninstall
kBuild: Linking SUPLoggerCtl
kBuild: Linking tstSDL
kBuild: Linking rdesktop-vrdp
/usr/bin/ld: error: undefined symbol: SSL_load_error_strings
>>> referenced by tcp.c:314 (/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/src/VBox/RDP/client-1.8.4/tcp.c:314)
>>>               /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/tcp.o:(tcp_tls_connect)

/usr/bin/ld: error: undefined symbol: SSL_library_init
>>> referenced by tcp.c:315 (/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/src/VBox/RDP/client-1.8.4/tcp.c:315)
>>>               /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/tcp.o:(tcp_tls_connect)

/usr/bin/ld: error: undefined symbol: BN_init
>>> referenced by ssl.c:143 (/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/src/VBox/RDP/client-1.8.4/ssl.c:143)
>>>               /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/ssl.o:(rdssl_rsa_encrypt)

/usr/bin/ld: error: undefined symbol: BN_init
>>> referenced by ssl.c:144 (/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/src/VBox/RDP/client-1.8.4/ssl.c:144)
>>>               /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/ssl.o:(rdssl_rsa_encrypt)

/usr/bin/ld: error: undefined symbol: BN_init
>>> referenced by ssl.c:145 (/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/src/VBox/RDP/client-1.8.4/ssl.c:145)
>>>               /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/ssl.o:(rdssl_rsa_encrypt)

/usr/bin/ld: error: undefined symbol: BN_init
>>> referenced by ssl.c:146 (/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/src/VBox/RDP/client-1.8.4/ssl.c:146)
>>>               /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/ssl.o:(rdssl_rsa_encrypt)

/usr/bin/ld: error: undefined symbol: HMAC_CTX_init
>>> referenced by ssl.c:321 (/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/src/VBox/RDP/client-1.8.4/ssl.c:321)
>>>               /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/ssl.o:(rdssl_hmac_md5)

/usr/bin/ld: error: undefined symbol: HMAC_CTX_cleanup
>>> referenced by ssl.c:325 (/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/src/VBox/RDP/client-1.8.4/ssl.c:325)
>>>               /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/ssl.o:(rdssl_hmac_md5)
kBuild: Linking VBoxDTrace
clang-6.0: error: linker command failed with exit code 1 (use -v to see invocation)
kmk: *** [/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/rdesktop-vrdp] Error 1
The failing command:
@/usr/local/bin/clang++60  -g                   '-Wl,-rpath,/usr/local/lib/virtualbox'   -m64   -o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/rdesktop-vrdp /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/tcp.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/asn.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/iso.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/mcs.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/secure.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/licence.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/rdp.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/orders.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/bitmap.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/cache.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/rdp5.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/channels.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/rdpdr.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/serial.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/printer.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/disk.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/parallel.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/printercache.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/mppc.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/pstcache.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/lspci.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/seamless.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/ssl.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/utils.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/rdesktop.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/xwin.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/xkeymap.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/ewmhints.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/xclip.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/cliprdr.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/ctrl.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/rdpsnd.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/rdpsnd_dsp.o /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/obj/rdesktop-vrdp/rdpsnd_oss.o   -L/usr/lib  -L/usr/local  -L/usr/local/lib   -liconv   -lX11   /usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.32/out/freebsd.amd64/debug/bin/VBoxRT.so   -lpthread   -lssl   -lcrypto 
kmk: *** Waiting for unfinished jobs....
kmk: *** Exiting with status 2
*** Error code 2

Stop.
make[1]: stopped in /usr/ports/emulators/virtualbox-ose
*** Error code 1
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-26 04:42:28 UTC
Thank you for your report Martin. Could you please provide additional information, including:

- Full build log (as an attachment)
- pkg version -v output (as an attachment)
- /etc/make.conf contents (as an attachment)
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-26 04:50:27 UTC

*** This bug has been marked as a duplicate of bug 232969 ***