Bug 240115 - fsdb man page does not mention ZFS, and probably wrong about btime being UFS2 only
Summary: fsdb man page does not mention ZFS, and probably wrong about btime being UFS2...
Status: Closed Not A Bug
Alias: None
Product: Documentation
Classification: Unclassified
Component: Manual Pages (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-26 00:38 UTC by Sean McBride
Modified: 2019-09-06 18:50 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean McBride 2019-08-26 00:38:48 UTC
It's a bit suspicious that FFS and UFS2 and both explicitly mentioned in the fsdb man page, but ZFS is not at all.

The sentence with UFS2 is probably wrong: "Note that btime is available on UFS2 file systems only."  ZFS also supports birth time.  Does fsdb really not support changing it on ZFS?

The sentence with FFS is perhaps incomplete: "Use this tool with extreme	caution--you can damage	an FFS file system beyond what fsck(8) can repair".  Can one damage other file systems too?
Comment 1 Conrad Meyer freebsd_committer 2019-08-26 03:52:25 UTC
Why is it suspicious?  fsdb is a UFS/FFS tool.

NAME
     fsdb – FFS debugging/editing tool

> "Note that btime is available on UFS2 file systems only."

The point of comparison is UFS1.  ZFS is out of scope of the page.
Comment 2 Sean McBride 2019-09-06 18:50:48 UTC
Thanks for your fast response.

I am pretty new to FreeBSD, so of course what seems obvious to you is perhaps unclear to newbies. :)

The name 'fsdb' suggested 'file system debug', I didn't expect it to apply to only one filesystem.

>NAME
>     fsdb – FFS debugging/editing tool

You know, I think I only saw one 'F' :), like:  'FS debugging/editing tool'

>The point of comparison is UFS1.  ZFS is out of scope of the page.

Which was not obvious to me before now.

------

Perhaps some wording could be improved nevertheless.  ex, that very first line could be:

NAME
     fsdb – FFS/UFS debugging/editing tool

"FFS" seems to be a lesser known acronym, ex: Wikipedia's disambiguation page lists "Flash File System" and "Formatted File System" but only "Berkeley Fast File System".

Even a short sentence to say that the tool supports no other file system would be nice IMHO.