Bug 240155 - www/nextcloud failes to build due to wrong python version
Summary: www/nextcloud failes to build due to wrong python version
Status: Closed DUPLICATE of bug 237795
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-27 20:13 UTC by Pablo
Modified: 2019-12-13 23:38 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (brnrd)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pablo 2019-08-27 20:13:08 UTC
www/nextcloud failes to build with this output:

```
root@buche:/usr/ports/www/nextcloud # make install
===>  Staging for nextcloud-php72-16.0.4
===>   nextcloud-php72-16.0.4 depends on package: php72-pecl-imagick>=2.2.2 - not found
===>   php72-pecl-imagick-3.4.4 depends on file: /usr/local/bin/phpize - found
===>   php72-pecl-imagick-3.4.4 depends on package: autoconf>0 - found
===>   php72-pecl-imagick-3.4.4 depends on package: pkgconf>=1.3.0_1 - found
===>   php72-pecl-imagick-3.4.4 depends on shared library: libMagickWand-6.so - not found
===>   ImageMagick6-nox11-6.9.10.57,1 depends on executable: gmake - found
===>   ImageMagick6-nox11-6.9.10.57,1 depends on package: pkgconf>=1.3.0_1 - found
===>   ImageMagick6-nox11-6.9.10.57,1 depends on package: ghostscript9-agpl-base>=9.16_2 - not found
===>   ghostscript9-agpl-base-9.27_2 depends on package: jbig2dec>=0.16 - found
===>   ghostscript9-agpl-base-9.27_2 depends on executable: gmake - found
===>   ghostscript9-agpl-base-9.27_2 depends on package: libiconv>=1.14_11 - found
===>   ghostscript9-agpl-base-9.27_2 depends on package: pkgconf>=1.3.0_1 - found
===>   ghostscript9-agpl-base-9.27_2 depends on shared library: libfontconfig.so - found (/usr/local/lib/libfontconfig.so)
===>   ghostscript9-agpl-base-9.27_2 depends on shared library: libfreetype.so - found (/usr/local/lib/libfreetype.so)
===>   ghostscript9-agpl-base-9.27_2 depends on shared library: libidn.so - found (/usr/local/lib/libidn.so)
===>   ghostscript9-agpl-base-9.27_2 depends on shared library: libjbig2dec.so - found (/usr/local/lib/libjbig2dec.so)
===>   ghostscript9-agpl-base-9.27_2 depends on shared library: libpaper.so - found (/usr/local/lib/libpaper.so)
===>   ghostscript9-agpl-base-9.27_2 depends on shared library: libpng.so - found (/usr/local/lib/libpng.so)
===>   ghostscript9-agpl-base-9.27_2 depends on shared library: libtiff.so - found (/usr/local/lib/libtiff.so)
===>   ghostscript9-agpl-base-9.27_2 depends on shared library: libcupsimage.so - not found
===>   cups-2.2.12 depends on executable: gmake - found
===>   cups-2.2.12 depends on package: libiconv>=1.14_11 - found
===>   cups-2.2.12 depends on package: pkgconf>=1.3.0_1 - found
===>   cups-2.2.12 depends on shared library: libavahi-client.so - not found
===>   avahi-app-0.7_2 depends on executable: msgfmt - found
===>   avahi-app-0.7_2 depends on executable: gmake - found
===>   avahi-app-0.7_2 depends on file: /usr/local/bin/intltool-extract - found
===>   avahi-app-0.7_2 depends on package: pkgconf>=1.3.0_1 - found
===>   avahi-app-0.7_2 depends on shared library: libexpat.so - found (/usr/local/lib/libexpat.so)
===>   avahi-app-0.7_2 depends on shared library: libdaemon.so - found (/usr/local/lib/libdaemon.so)
===>   avahi-app-0.7_2 depends on shared library: libdbus-glib-1.so - found (/usr/local/lib/libdbus-glib-1.so)
===>   avahi-app-0.7_2 depends on shared library: libdbus-1.so - found (/usr/local/lib/libdbus-1.so)
===>   avahi-app-0.7_2 depends on shared library: libgdbm.so - found (/usr/local/lib/libgdbm.so)
===>   avahi-app-0.7_2 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   avahi-app-0.7_2 depends on shared library: libglib-2.0.so - found (/usr/local/lib/libglib-2.0.so)
===>   avahi-app-0.7_2 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   avahi-app-0.7_2 depends on shared library: libgirepository-1.0.so - not found
===>   gobject-introspection-1.56.1,1 depends on executable: cairo-trace - not found
===>   cairo-1.16.0,2 depends on package: pkgconf>=1.3.0_1 - found
===>   cairo-1.16.0,2 depends on package: xorgproto>=0 - found
===>   cairo-1.16.0,2 depends on package: xorgproto>=0 - found
===>   cairo-1.16.0,2 depends on file: /usr/local/libdata/pkgconfig/pixman-1.pc - found
===>   cairo-1.16.0,2 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   cairo-1.16.0,2 depends on file: /usr/local/libdata/pkgconfig/xext.pc - found
===>   cairo-1.16.0,2 depends on file: /usr/local/libdata/pkgconfig/xrender.pc - found
===>   cairo-1.16.0,2 depends on file: /usr/local/libdata/pkgconfig/xcb.pc - found
===>   cairo-1.16.0,2 depends on shared library: libfreetype.so - found (/usr/local/lib/libfreetype.so)
===>   cairo-1.16.0,2 depends on shared library: libpng.so - found (/usr/local/lib/libpng.so)
===>   cairo-1.16.0,2 depends on shared library: libfontconfig.so - found (/usr/local/lib/libfontconfig.so)
===>   cairo-1.16.0,2 depends on shared library: libglib-2.0.so - found (/usr/local/lib/libglib-2.0.so)
===>   cairo-1.16.0,2 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   cairo-1.16.0,2 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   cairo-1.16.0,2 depends on shared library: libGL.so - not found
===>   mesa-libs-18.3.2_1 depends on file: /usr/local/libdata/pkgconfig/pthread-stubs.pc - found
===>   mesa-libs-18.3.2_1 depends on executable: bison - found
===>   mesa-libs-18.3.2_1 depends on executable: msgfmt - found
===>   mesa-libs-18.3.2_1 depends on executable: gmake - found
===>   mesa-libs-18.3.2_1 depends on package: pkgconf>=1.3.0_1 - found
===>   mesa-libs-18.3.2_1 depends on file: /usr/local/bin/python2.7 - found
===>   mesa-libs-18.3.2_1 depends on package: llvm80>=3.9.0_4 - not found
===>  llvm80-8.0.1_2 needs Python 3.6 at least, but 2.7 was specified.
*** Error code 1

Stop.
make[16]: stopped in /usr/ports/devel/llvm80

```
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-28 03:07:58 UTC
Thank you for the report Pablo.

Does the build succees if llvm80 is built/installed first, then re-running the nextcloud build?
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2019-12-13 23:38:08 UTC

*** This bug has been marked as a duplicate of bug 237795 ***