Bug 240214 - graphics/geeqie 1.5.1: Doesn't build: [Makefile:505: html/GuideIndex.html] Error 1
Summary: graphics/geeqie 1.5.1: Doesn't build: [Makefile:505: html/GuideIndex.html] Er...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-30 19:02 UTC by Vladimir Omelchuk
Modified: 2019-09-09 14:19 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (amdmi3)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Omelchuk 2019-08-30 19:02:43 UTC
[...]
if [ -x "/usr/local/bin/gnome-doc-tool" ]; then \
	"/usr/local/bin/gnome-doc-tool" html -o html ./docbook/GuideIndex.xml ; \
else \
	echo "gnome-doc-tool not found, html is not built" ; \
fi
getopt: illegal option -- s
getopt: illegal option -- s
getopt: illegal option -- f
[...]
getopt: illegal option -- h
getopt: illegal option -- p
Usage: gnome-doc-tool html [OPTIONS] FILE
Convert FILE into HTML.
[...]
gmake[4]: *** [Makefile:505: html/GuideIndex.html] Error 1
gmake[4]: Leaving directory '/usr/ports/graphics/geeqie/work/geeqie-1.5.1/doc'
gmake[3]: *** [Makefile:440: install-data-am] Error 2
gmake[3]: Leaving directory '/usr/ports/graphics/geeqie/work/geeqie-1.5.1/doc'
gmake[2]: *** [Makefile:396: install-am] Error 2
gmake[2]: Leaving directory '/usr/ports/graphics/geeqie/work/geeqie-1.5.1/doc'
gmake[1]: *** [Makefile:674: install-recursive] Error 1
gmake[1]: Leaving directory '/usr/ports/graphics/geeqie/work/geeqie-1.5.1'
*** Error code 2

Stop.
make: stopped in /usr/ports/graphics/geeqie

root@vladiom:~ # uname -srm
FreeBSD 12.0-RELEASE-p10 amd64
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-08-30 20:40:01 UTC
The error appears if gnome-doc-utils installed.

Caused by this lines in work/geeqie-1.5.1/doc/Makefile.am:

 9         rm -rf html; mkdir html; cp $(srcdir)/icons/* html/
     10         if [ -x "$(GNOME_DOC_TOOL)" ]; then \
     11                 "$(GNOME_DOC_TOOL)" html -o html $(srcdir)/docbook/GuideIndex.xml ; \
     12         else \
     13                 echo "gnome-doc-tool not found, html is not built" ; \
     14         fi
     15 
     16 html: html/GuideIndex.html
     17 
     18 install-data-hook: html
     19         if [ -x "$(GNOME_DOC_TOOL)" ]; then \
     20                 $(MKDIR_P) "$(DESTDIR)$(helpdir)" || exit 1; \
     21                 cd $(srcdir)/html; for f in * ; do $(INSTALL_DATA) "$$f" "$(DESTDIR)$(helpdir)/$$f" ; done; \
     22                 ln -s -f GuideIndex.html "$(DESTDIR)$(helpdir)/index.html" ; \
     23         fi
     24
Comment 2 commit-hook freebsd_committer 2019-09-09 14:13:35 UTC
A commit references this bug:

Author: amdmi3
Date: Mon Sep  9 14:13:06 UTC 2019
New revision: 511631
URL: https://svnweb.freebsd.org/changeset/ports/511631

Log:
  - Fix build in presence of gnome-doc-utils

  PR:		240214
  Reported by:	admin@vladiom.com.ua

Changes:
  head/graphics/geeqie/files/patch-Makefile.am