Bug 240326 - audio/linux-c7-alsa-plugins-oss - No sound in some games
Summary: audio/linux-c7-alsa-plugins-oss - No sound in some games
Status: Closed DUPLICATE of bug 240043
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-emulation mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-04 07:38 UTC by Stefan Rumetshofer
Modified: 2019-09-05 09:02 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (emulation)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Rumetshofer 2019-09-04 07:38:59 UTC
With linux-c7-alsa* i have no sound in some of my games. For example when i start linux-doom3 i get the following message:

dlopen(libasound.so.2)
asoundlib version: 1.1.6
Alsa is available
------ Alsa Sound Initialization -----
ALSA lib conf.c:3639:(config_file_open) cannot access file /etc/alsa/conf.d/50-oss.conf
ALSA lib conf.c:3559:(snd_config_hooks_call) function snd_config_hook_load returned error: No such file or directory
ALSA lib conf.c:4013:(snd_config_update_r) hooks failed, removing configuration
snd_pcm_open SND_PCM_STREAM_PLAYBACK 'default' failed: No such file or directory
dlclose
WARNING: sound subsystem disabled

--------------------------------------
----------- Alsa Shutdown ------------
--------------------------------------

The symlink in /compat/linux/etc/alsa/conf.d/50-oss.conf goes to nowhere.
Correcting the link to the right place in /compat/linux/usr/share/alsa/alsa.conf.d/50-oss.conf also makes the sound not working but results in another Error:

dlopen(libasound.so.2)
asoundlib version: 1.1.6
Alsa is available
------ Alsa Sound Initialization -----
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
snd_pcm_open SND_PCM_STREAM_PLAYBACK 'default' failed: Invalid argument
dlclose
WARNING: sound subsystem disabled

--------------------------------------
----------- Alsa Shutdown ------------
--------------------------------------

with linux-quake4 i get the same error messages and sound is also not working.

The following (linux)ports are installed on my system:

linux-c7-alsa-lib-1.1.6            =   up-to-date with remote
linux-c7-alsa-plugins-oss-1.1.6    =   up-to-date with remote
linux-c7-dri-18.0.5                =   up-to-date with remote
linux-c7-elfutils-libelf-0.172     =   up-to-date with remote
linux-c7-expat-2.1.0_2             =   up-to-date with remote
linux-c7-fontconfig-2.13.0         =   up-to-date with remote
linux-c7-freetype-2.8              =   up-to-date with remote
linux-c7-libglvnd-1.0.1            =   up-to-date with remote
linux-c7-libpciaccess-0.14         =   up-to-date with remote
linux-c7-libpng-1.5.13_2           =   up-to-date with remote
linux-c7-sdl-1.2.15_1              =   up-to-date with remote
linux-c7-wayland-1.15.0            =   up-to-date with remote
linux-c7-xorg-libs-7.7_6           =   up-to-date with remote

As i can remember there were no problems with the linux-c6 ports, but i can't use them because i need c7 for my radeon GPU.
Comment 1 Serge Volkov 2019-09-04 08:06:49 UTC
A similar topic is discussed here https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=240043

Now I am using a temporary workaround:

pkg delete -f linux-c7-alsa-lib
pkg install gsed
portsnap fetch extract
cd /usr/ports/audio/linux-c6-alsa-lib/
gsed -i -E 's/USES=\t*linux:c6/USES=\t\tlinux:c7/Ig' Makefile
make install clean
pkg lock -xy linux-c7-alsa-lib 

In fact, this is a replacement for linux-c7-alsa-lib with linux-c6-alsa-lib. You can try it.
Comment 2 Tijl Coosemans freebsd_committer 2019-09-04 09:40:49 UTC
(In reply to Stefan Rumetshofer from comment #0)
You can remove the symlink.  It was removed on August 25 so you should be seeing a package update for linux-c7-alsa-plugins-oss.  What version of FreeBSD do you run?  Are you perhaps using the quarterly packages?
Comment 3 Stefan Rumetshofer 2019-09-05 07:17:15 UTC
Replacing the c7 port with the c6 port didn't help, but completely removing the linux-c7-alsa-lib works for these games and now i have sound again.
I'm on 12.0-RELEASE with quaterly ports.
Comment 4 Tijl Coosemans freebsd_committer 2019-09-05 09:02:44 UTC

*** This bug has been marked as a duplicate of bug 240043 ***