Bug 240384 - sysutils/u-boot-rockpro64: fails to build
Summary: sysutils/u-boot-rockpro64: fails to build
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Uboot FreeBSD Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-07 05:01 UTC by me
Modified: 2019-09-12 07:48 UTC (History)
1 user (show)

See Also:
w.schwarzenfeld: maintainer-feedback?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description me 2019-09-07 05:01:44 UTC
I failed to build this port on post-build phrase, here is the relevant error log:

--- post-build ---
mkimage -n rk3399 -T rksd -d /usr/local/share/linux-rkbin/bin/rk33/rk3399_ddr_800MHz_v1.23.bin /usr/ports/sysutils/u-boot-rockpro64/work/u-boot-2019.07/idbloader.img
Image Type:   Rockchip RK33 (SD/MMC) boot image
Data Size:    79872 bytes
cat /usr/local/share/linux-rkbin/bin/rk33/rk3399_miniloader_v1.19.bin >> /usr/ports/sysutils/u-boot-rockpro64/work/u-boot-2019.07/idbloader.img
(cd /usr/ports/sysutils/u-boot-rockpro64/work/u-boot-2019.07 && rk-trust_merger /usr/local/share/linux-rkbin/rktrust/RK3399TRUST.ini)
ELF binary type "0" not known.
sh: rk-trust_merger: Exec format error
*** [post-build] Error code 126

make: stopped in /usr/ports/sysutils/u-boot-rockpro64
1 error

make: stopped in /usr/ports/sysutils/u-boot-rockpro64

I'm running 12.0-RELEASE on amd64.

The reason why I'm trying to build this manually is because I want to make a similar port for rockpi4 which is also a good SBC build on RK3399, the defconfig is already in uboot repo, It only need to change the board config line to rock-pi-4-rk3399_defconfig.
Could any add this port to the tree, since I'm don't know how to add a new port to the tree.
Comment 1 Bugzilla Automation freebsd_committer 2019-09-07 05:01:44 UTC
Maintainer informed via mail
Comment 2 me 2019-09-12 07:48:34 UTC
Hi I just found out, the error caused by my custom kernel which lacks of Linux compatibility support. Switch to General kernel everything works fine. Thanks for your effort to make RK3399 working