Bug 240386 - www/gohugo: Update to 0.58.2
Summary: www/gohugo: Update to 0.58.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kai Knoblich
URL: https://github.com/gohugoio/hugo/rele...
Keywords:
: 240591 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-07 07:37 UTC by ben.lavery@hashbang0.com
Modified: 2019-09-16 11:14 UTC (History)
1 user (show)

See Also:


Attachments
svn diff to upgrade to 0.58.1 (10.93 KB, patch)
2019-09-07 07:37 UTC, ben.lavery@hashbang0.com
no flags Details | Diff
gohugo-0.58.2.diff (10.61 KB, patch)
2019-09-16 10:26 UTC, Kai Knoblich
kai: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ben.lavery@hashbang0.com 2019-09-07 07:37:44 UTC
Created attachment 207255 [details]
svn diff to upgrade to 0.58.1

gohugo has been updated to 0.58.1
(https://github.com/gohugoio/hugo/releases/tag/v0.58.1)

The attached svn diff brings this port up from 0.57.1 to 0.58.1

Change log:
- Default to Extended builds with SCSS/SASS support
- Hugo 0.58 adds the long sought after Exif (docs) method on image and a bunch of useful image filters (docs), courtesy of @disintegration's great Gift image library.
- Bug fixes

- portlint: OK (looks fine.)
- testport: OK (poudriere: <11.3-RELEASE, 11.3-STABLE, 12.0-RELEASE, 12.0-STABLE, and 13.0-CURRENT>, < amd64/i386 >, <manpages + with/without extended> tested)
Comment 1 Kai Knoblich freebsd_committer 2019-09-16 10:24:07 UTC
*** Bug 240591 has been marked as a duplicate of this bug. ***
Comment 2 Kai Knoblich freebsd_committer 2019-09-16 10:26:45 UTC
Created attachment 207534 [details]
gohugo-0.58.2.diff
Comment 3 commit-hook freebsd_committer 2019-09-16 11:11:31 UTC
A commit references this bug:

Author: kai
Date: Mon Sep 16 11:11:22 UTC 2019
New revision: 512161
URL: https://svnweb.freebsd.org/changeset/ports/512161

Log:
  www/gohugo: Update to 0.58.2

  * Set option EXTENDED as default to enable SCCS/Sass support out of the box.

  While I'm here:

  * Group variables together that are related to the OPTIONS block.

  Changelog:

  https://github.com/gohugoio/hugo/releases/tag/v0.58.2

  PR:		240386
  Submitted by:	ben.lavery@hashbang0.com (maintainer)

Changes:
  head/www/gohugo/Makefile
  head/www/gohugo/distinfo
Comment 4 Kai Knoblich freebsd_committer 2019-09-16 11:14:11 UTC
Committed, thank you for the patches!