Bug 240437 - ping6: unable to limit access to system.dns service: Invalid argument
Summary: ping6: unable to limit access to system.dns service: Invalid argument
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 12.0-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Alan Somers
URL:
Keywords:
: 240511 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-09 08:25 UTC by Raúl
Modified: 2019-09-11 19:52 UTC (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl 2019-09-09 08:25:04 UTC
On r352027 and later (tested up to r352054) running ping6 without parameters gives this error:

[....]
# ping6
ping6: unable to limit access to system.dns service: Invalid argument
[....]

Same ping6 on r351925 works.
Comment 1 Alan Somers freebsd_committer 2019-09-09 14:11:10 UTC
The problem is that r340363 (to libcasper) never got MFCed.  oshogbo, is there a good reason not to MFC that change?  If so, then I can fix ping6 to use the older casper strings.
Comment 2 wolfgang 2019-09-10 20:09:52 UTC
ping6 also fails with the same message when called with parameters, tested on r352139
Comment 3 Mariusz Zaborski freebsd_committer 2019-09-10 21:24:08 UTC
Alan I just merged all relevant things to stable/12.
Comment 4 wolfgang 2019-09-11 06:56:44 UTC
I can confirm ping6 works for me now with userland from r352194. Unfortunately kernel from r352194 hangs at boot, see PR#240487
Comment 5 Alan Somers freebsd_committer 2019-09-11 18:13:27 UTC
*** Bug 240511 has been marked as a duplicate of this bug. ***
Comment 6 Alan Somers freebsd_committer 2019-09-11 19:52:21 UTC
Thanks for the quick fix, oshogbo.