Bug 240493 - net/scapy: Update to 2.4.3, fix fetch, update WWW
Summary: net/scapy: Update to 2.4.3, fix fetch, update WWW
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Muhammad Moinur Rahman
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2019-09-11 08:46 UTC by Li-Wen Hsu
Modified: 2019-09-11 10:25 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (bofh)


Attachments
scapy-2.4.3.diff (9.26 KB, patch)
2019-09-11 08:46 UTC, Li-Wen Hsu
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Li-Wen Hsu freebsd_committer 2019-09-11 08:46:33 UTC
Created attachment 207373 [details]
scapy-2.4.3.diff

- Update to 2.4.3
- Change MASTER_SITE to PYPI for better availability
- Update WWW
Comment 1 Li-Wen Hsu freebsd_committer 2019-09-11 08:48:14 UTC
bofh: since this is used in the CI system, I can take care of this update if you have no time on this soon. Thanks!
Comment 2 Muhammad Moinur Rahman freebsd_committer 2019-09-11 10:04:54 UTC
I believe I committed 2.4.3 a couple of days ago on the bug for the CI. And definitely you can.
Comment 3 Li-Wen Hsu freebsd_committer 2019-09-11 10:07:04 UTC
Yes I was also wonder why it hasn't been in the pkg repository, and I found it was reverted:

http://svnweb.freebsd.org/changeset/ports/511268
Comment 4 Muhammad Moinur Rahman freebsd_committer 2019-09-11 10:08:33 UTC
(In reply to Li-Wen Hsu from comment #3)
Oops. Give me couple of minutes.
Comment 5 commit-hook freebsd_committer 2019-09-11 10:24:53 UTC
A commit references this bug:

Author: bofh
Date: Wed Sep 11 10:24:29 UTC 2019
New revision: 511811
URL: https://svnweb.freebsd.org/changeset/ports/511811

Log:
  inet/scapy: Update version 2.4.2=>2.4.3

  - Use net/py-pypcap instead of net/py-pcap as dnet and py-pcap will be
    deprecated in future scapy versions. One other reason is py-pcap is
    failing with python3. [1]
  - Change MASTER_SITE to PYPI for better availability [2]
  - Update WWW [2]

  PR:		239380 [1] 240493 [2]
  Submitted by:	lwhsu [1] [2]

Changes:
  head/net/scapy/Makefile
  head/net/scapy/distinfo
  head/net/scapy/files/
  head/net/scapy/pkg-descr