Bug 240513 - [PATCH]: sys/x86/x86/tsc.c: Use gender-neutral pronoun in comment
Summary: [PATCH]: sys/x86/x86/tsc.c: Use gender-neutral pronoun in comment
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords: easy, patch
: 240512 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-11 18:58 UTC by Neel Chauhan
Modified: 2019-09-11 21:13 UTC (History)
1 user (show)

See Also:


Attachments
Patch (Revision 1) (482 bytes, patch)
2019-09-11 18:58 UTC, Neel Chauhan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan 2019-09-11 18:58:05 UTC
Created attachment 207393 [details]
Patch (Revision 1)

On line 283 in sys/x86/x86/tsc.c, I saw the following comment:

 * User did not give the order about calibration.
 * If he did, we do not try to guess.

We can't assume all FreeBSD users are male. They could be female, non-binary, etc. I have a patch which changes the comment to:

 * User did not give the order about calibration.
 * If they did, we do not try to guess.
Comment 1 Neel Chauhan 2019-09-11 18:58:17 UTC
*** Bug 240512 has been marked as a duplicate of this bug. ***
Comment 2 Conrad Meyer freebsd_committer 2019-09-11 21:13:31 UTC
We're not individually patching every single instance of pronouns in comments.