Bug 240784 - graphics/gstreamer1-plugins-vulkan: fails to build if libdrm + wayland-protocols are installed
Summary: graphics/gstreamer1-plugins-vulkan: fails to build if libdrm + wayland-protoc...
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-multimedia mailing list
URL:
Keywords: needs-patch
Depends on:
Blocks: 231406
  Show dependency treegraph
 
Reported: 2019-09-24 08:16 UTC by Jongsung Kim
Modified: 2019-09-29 03:34 UTC (History)
1 user (show)

See Also:


Attachments
Build failure log (61.13 KB, text/plain)
2019-09-24 08:24 UTC, Jongsung Kim
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jongsung Kim 2019-09-24 08:16:00 UTC

    
Comment 1 Jongsung Kim 2019-09-24 08:24:10 UTC
Created attachment 207754 [details]
Build failure log

Attached build failure log. Build process failed while compiling vkwindow_wayland.c:

vkwindow_wayland.c:27:10: fatal error: 'linux/input.h' file not found
#include <linux/input.h>
         ^~~~~~~~~~~~~~~
Comment 2 Jongsung Kim 2019-09-24 08:28:32 UTC
"make" command from the directory fails too with same error message.
Comment 3 Jan Beich freebsd_committer 2019-09-29 03:34:19 UTC
Looks like Wayland support is opportunistically enabled if dependencies are installed. May need to be explicit and optional like ports r483908.