Bug 240792 - net/kea: 1.6.0 does not build without DOCS
Summary: net/kea: 1.6.0 does not build without DOCS
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-24 14:22 UTC by Christian Ullrich
Modified: 2019-09-25 04:20 UTC (History)
2 users (show)

See Also:
apevnev: maintainer-feedback+


Attachments
Patch. (647 bytes, patch)
2019-09-24 14:22 UTC, Christian Ullrich
chris: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Ullrich 2019-09-24 14:22:54 UTC
Created attachment 207770 [details]
Patch.

Since the upgrade to 1.6.0, net/kea does not build, or rather, stage, anymore:

[...]
 install  -m 0644  examples/https/nginx/kea-nginx.conf '/wrkdirs/usr/ports/net/kea/work/stage/usr/local/share/doc/kea/examples/https/nginx'
Making install in m4macros
/usr/bin/make  install-exec-hook
mkdir -p /wrkdirs/usr/ports/net/kea/work/stage/var/log/
mkdir -p /wrkdirs/usr/ports/net/kea/work/stage/var/run/kea
make[1]: don't know how to make install-pkgconfigDATA. Stop

make[1]: stopped in /wrkdirs/usr/ports/net/kea/work/kea-1.6.0
*** Error code 2

Stop.
make: stopped in /usr/ports/net/kea


This is caused by these lines in the Makefile:


DOCS_MAKE_ARGS_OFF=	\
		INSTALL_STRIP_PROGRAM="${WRKSRC}/install-sh -c -s" \
		INSTALL_STRIP_FLAG="-s" \
		INSTALL_PROGRAM_ENV="STRIPPROG=${STRIP}"
DOCS_INSTALL_TARGET_OFF=	\
		install-exec-am \
		install-pkgconfigDATA \
		install-pkgincludeHEADERS


They have been in there from the start of the port, I have no idea what they do or what they may have been necessary, but Kea 1.6.0 does not know the target anymore, so I think they need to go. Patch attached.
Comment 1 Kurt Jaeger freebsd_committer 2019-09-24 20:03:11 UTC
testbuild without DOCS and this patch is fine.
Comment 2 Andrey Pevnev 2019-09-24 20:33:59 UTC
Comment on attachment 207770 [details]
Patch.

sure, let’s take it out
Comment 3 Kurt Jaeger freebsd_committer 2019-09-25 04:20:17 UTC
Committed, thanks!
Comment 4 commit-hook freebsd_committer 2019-09-25 04:20:45 UTC
A commit references this bug:

Author: pi
Date: Wed Sep 25 04:20:12 UTC 2019
New revision: 512763
URL: https://svnweb.freebsd.org/changeset/ports/512763

Log:
  net/kea: fix build without DOCS

  PR:		240792
  Submitted by:	Christian Ullrich <chris@chrullrich.net>
  Approved by:	Andrey Pevnev <apevnev@me.com> (maintainer)

Changes:
  head/net/kea/Makefile