Bug 240826 - devel/llvm90: EXTRAS option broken
Summary: devel/llvm90: EXTRAS option broken
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Brooks Davis
URL:
Keywords:
: 240872 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-25 23:39 UTC by rozhuk.im
Modified: 2019-10-28 21:04 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (brooks)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rozhuk.im 2019-09-25 23:39:30 UTC
If EXTRAS option unset on install got:
...
===>   Registering installation for llvm90-9.0.0 as automatic
pkg-static: Unable to access file /tmp/ports/usr/ports/devel/llvm90/work/stage/usr/local/llvm90/bin/clangd:No such file or directory
*** Error code 74
Comment 1 commit-hook freebsd_committer 2019-10-01 16:01:45 UTC
A commit references this bug:

Author: brooks
Date: Tue Oct  1 16:01:11 UTC 2019
New revision: 513490
URL: https://svnweb.freebsd.org/changeset/ports/513490

Log:
  Fix build with EXTRAS disabled.

  clangd is part of EXTRAS, not CLANG.

  PR:		240826
  Reported by:	rozhuk.im@gmail.com

Changes:
  head/devel/llvm90/Makefile.COMMANDS
  head/devel/llvm90/pkg-plist
Comment 2 Brooks Davis freebsd_committer 2019-10-01 16:10:55 UTC
*** Bug 240872 has been marked as a duplicate of this bug. ***
Comment 3 commit-hook freebsd_committer 2019-10-28 21:04:46 UTC
A commit references this bug:

Author: brooks
Date: Mon Oct 28 21:04:18 UTC 2019
New revision: 515935
URL: https://svnweb.freebsd.org/changeset/ports/515935

Log:
  MFH: r513490 r514194 r515213

  Fix build with EXTRAS disabled.

  clangd is part of EXTRAS, not CLANG.

  PR:		240826
  Reported by:	rozhuk.im@gmail.com

  Rollup of fixes since the 9.0.0 release.

  - Change the default -march for i386 from i486 to i586.  This avoids
    the need for libatomics and had been the defacto default for some
    time. [0]

  - Add -m(no)-spe to clang. (powerpc)

  - Deduce MIPS specific ELF header flags from `emulation`. (mips)

  - Fix a variety of assertions and compile/link errors including crashes
    with CPUTYPE=haswell. [1]

  - Switch back to https for downloads. [2]

  The new patches were initially committed to FreeBSD src by dim@.

  PR:		240918 [0], 240759 [1], 240870 [2]
  Reported by:	jbeich [0,1],  Miyashita Touka <imagin8r@protonmail.com> [2]

  Fix build without CLANG enabled. [0]

  Fix LLD build where PREFIX != LOCALBASE. [1]

  powerpc64: add configure option to select ELFv2 ABI [2]

  In preparation for compiler+ABI change in PowerPC64, this change adds a
  configure option to select ELFv2 as default powerpc64 ABI when compiling
  llvm90.

  The new option automatically set when ELFv2 environment is detected
  (when PPC_ABI=ELFv2)

  PR:		241400 [1], 241410 [0]
  Submitted by:	Alfredo Dal'Ava J?nior [2]
  Differential Revision:	https://reviews.freebsd.org/D22100 [2]

  Approved by:	portmgr (blanket for build and reliability fixes)

Changes:
_U  branches/2019Q4/
  branches/2019Q4/devel/llvm90/Makefile
  branches/2019Q4/devel/llvm90/Makefile.COMMANDS
  branches/2019Q4/devel/llvm90/files/clang/patch-freebsd-r352030
  branches/2019Q4/devel/llvm90/files/clang/patch-freebsd-r352539
  branches/2019Q4/devel/llvm90/files/clang/patch-freebsd-r352586
  branches/2019Q4/devel/llvm90/files/lld/
  branches/2019Q4/devel/llvm90/files/patch-freebsd-r352318
  branches/2019Q4/devel/llvm90/files/patch-freebsd-r352629
  branches/2019Q4/devel/llvm90/files/ppc64-elfv2/
  branches/2019Q4/devel/llvm90/pkg-plist