Bug 240887 - x11-wm/xfce4: blank or black window decorations, without rounded borders
Summary: x11-wm/xfce4: blank or black window decorations, without rounded borders
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Guido Falsi
URL: https://bugzilla.xfce.org/show_bug.cg...
Keywords: needs-qa, regression
Depends on:
Blocks:
 
Reported: 2019-09-27 22:39 UTC by Aaron Farias
Modified: 2020-04-07 15:35 UTC (History)
11 users (show)

See Also:
madpilot: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Farias 2019-09-27 22:39:38 UTC
Hi,

I have recently updated XFCE to version 4.14 included in the FreeBSD ports collection.

While it is working generally and everything worked fine for me in my testing users are reporting an issue with the window manager.

With certain graphics hardware/driver combinations they report blank or black window decorations, without rounded borders or other eye candy.

The original user messages describing the issue can be viewed here:

https://lists.freebsd.org/pipermail/freebsd-xfce/2019-September/002434.html
https://lists.freebsd.org/pipermail/freebsd-xfce/2019-September/002438.html

I'm trying to gather more information about this.

What is needed to try to address the issue?

Thanks in advance!
Comment 1 Olivier Duchateau 2019-09-28 09:12:13 UTC
(In reply to Aaron Farias from comment #0)

Which version of FreeBSD is running? If it is not -CURRENT, I suggest using Xorg drivers (no response about this workaround from poster).

Make sure you (or your users) use Gtk3 compatible theme.

- Greybird contains Gtk2, Gtk3, and xfwm4 themes
- Adwaita contains only Gtk2 and Gtk3 themes. It works fine with default xfwm4 theme (not selected by default!)
Comment 2 Guido Falsi freebsd_committer 2019-09-29 14:47:40 UTC
I have already filed a bug report upstream in the XFCE bugzilla.

It could be useful if affcted users could reply there performing the tests required by the XFCE developers. [1]


[1] https://bugzilla.xfce.org/show_bug.cgi?id=15990
Comment 3 Matt Smith 2019-09-30 16:16:48 UTC
I had this problem. Using 12.0-RELEASE with the i915 drm-kmod driver loaded via kld_list="/boot/modules/i915kms.ko acpi_video". It worked fine with 4.12, broke with 4.14.

For me adding this to /usr/local/etc/X11/xorg.conf.d/driver-intel.conf has totally fixed the problem:

Section "Device"
	Identifier	"Card0"
	Driver		"intel"
	# BusID		"PCI:1:0:0"
EndSection

So it appears to be an issue using the modesetting drivers on 12.x.

My card is:

vgapci0@pci0:0:2:0:	class=0x030000 card=0x90ab104d chip=0x01268086 rev=0x09 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '2nd Generation Core Processor Family Integrated Graphics Controller'
    class      = display
    subclass   = VGA
Comment 4 Aaron Farias 2019-10-01 19:26:56 UTC
(In reply to Olivier Duchateau from comment #1)
Hi I'm actually using FreeBSD --current

FreeBSD freebsduser.hopto.org 13.0-CURRENT FreeBSD 13.0-CURRENT GENERIC-NODEBUG  amd64

that's my information and the drivers that I am using is radeonkms.
Comment 5 Guido Falsi freebsd_committer 2019-10-02 07:24:52 UTC
(In reply to Aaron Farias from comment #4)

Thanks for the information, could you also post the output of "pciconf -lv vgapci0" so we can see exactly what your graphics hardware is?

Thanks you!
Comment 6 marek 2019-11-22 12:24:08 UTC
I had the same issue under scfb driver for Xorg. I fixed this by installing Intel's drivers.

OS: FreeBSD 12.1-RELEASE-p1
HW: Lenovo ThinkPad X201 (Intel Core i5 Sandy Bridge CPU)

Intel graphics card details:
vgapci0@pci0:0:2:0:     class=0x030000 card=0x215a17aa chip=0x00468086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Core Processor Integrated Graphics Controller'
    class      = display
    subclass   = VGA

Installed drivers:
drm-fbsd12.0-kmod-4.16.g20191024
drm-kmod-g20190710
xf86-video-intel-2.99.917.20181203

DRM driver is loaded by:
kld_list="/boot/modules/i915kms.ko"

Xorg Intel driver is detected automatically when the Xorg starts.
Comment 7 Philipp 2020-02-16 15:27:21 UTC
Hi,

I have the same problem and cannot seem to work around it.
My window title bars are always black as of FreeBSD 12.1.

The black window titlebar happens with both my Radeon card (Juniper PRO Radeon HD 5750) and my onboard Intel Video.
I use "radeonkms" for the Radeon Card and "i915" for the Intel Onboard Video as parameter to kld_list in rc.conf.
I even built the port "graphics/drm-fbsd12.0-kmod" and changed the kld_list value to "/boot/modules/radeonkms.ko" as suggested by the output of "make install".
(not sure if it might have helped, I am new to FreeBSD).

I even uninstalled my Radeon card to see if Onboard Video alone works (i915), but it has the same problem.

Note that this happens independent of the chosen theme in "XFCE Appearance". 
It happens with both compositor on and off from "XFCE Window Manager Tweaks" dialog.

The problem did not happen for me when in FreeBSD 11.1.

Thanks in advance.
Comment 8 Olivier Duchateau 2020-02-16 16:52:11 UTC
(In reply to Philipp from comment #7)

Instead to use DRM kernel modules, try with Xorg drivers.
Comment 9 Philipp 2020-02-24 05:20:16 UTC
(reply to comment #8 from Olivier)

I tried xf86-video-ati driver today, but X server will not start with this installed. (I installed with pkg).
It will not start no matter if radeonkms is enabled or not.
I get a black screen and this message:
"drmn0: error: No GEM object associated to handle 0x...., can't create framebuffer".

To my understanding, the kms driver is preferred and has better performance. It does work great, except for the black window title bars :-)

Is it maybe a bug that XFCE has to fix?
Comment 10 Alexander Vereeken 2020-02-24 05:47:05 UTC
I can confirm this also happends with my rx 570 using xf86-video-amdgpu but also found out that this disappear when xf86-video-scfb or vesa is used.
Comment 11 Marko Cupać 2020-02-24 11:08:11 UTC
Since latest batch of port upgrades I got my window decorations back to normal when using modesetting driver.

Could it be that the bug was in xorg-server, squashed in xorg-server-1.20.7,1?
Comment 12 Philipp 2020-02-24 15:33:31 UTC
(replying to Comment #11 from Marko)

That sounds promising. Is there a way to get this new xorg server version (without having to compile xorg myself) ?
"freebsd-update fetch" says I'm on 12.1-RELEASE-p2 and no updates are ready.
My xorg log file says "X.Org X Server 1.18.4" (xorg-server-1.18.4_13,1).
Comment 13 Alexander Vereeken 2020-02-24 15:45:37 UTC
You can use the latest repository instead of quarterly.
Comment 14 Alexander Vereeken 2020-02-24 16:14:11 UTC
(In reply to Marko Cupać from comment #11)

Wow, thanks! the issue is gone for me.
Comment 15 Philipp 2020-02-25 05:59:08 UTC
Changing pkg config from quarterly to latest solved the issue for me too. Thanks!
Comment 16 Guido Falsi freebsd_committer 2020-03-15 12:02:02 UTC
It looks like the Xorg server update really fixes this issue.

If that proves right I plan to close this bug report as "Overcome by events" once the Xorg server update hits the quarterly branch and is available in the binary package set.
Comment 17 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-31 05:51:31 UTC
^Triage: Assign to committer resolving, pending xorg-server update in new (next) quarterly branch
Comment 18 Guido Falsi freebsd_committer 2020-04-07 15:35:46 UTC
I'm closing this bug now that the new quarterly branch packages are available.

These include the new Xorg-server which fixes this problem.