Bug 240923 - x11-toolkits/lesstif: Remove dependency on libXp
Summary: x11-toolkits/lesstif: Remove dependency on libXp
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-29 20:34 UTC by Niclas Zeising
Modified: 2019-09-30 22:27 UTC (History)
0 users

See Also:
dinoex: maintainer-feedback+


Attachments
v1 (1.45 KB, patch)
2019-09-29 20:34 UTC, Niclas Zeising
no flags Details | Diff
v1 (1.48 KB, patch)
2019-09-30 14:40 UTC, Niclas Zeising
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Niclas Zeising freebsd_committer 2019-09-29 20:34:28 UTC
Created attachment 207945 [details]
v1

libXp has been deprecated and is slated for removal on November 1:st.  Attached patch fixes x11-toolkits to build without it.
Comment 1 Dirk Meyer freebsd_committer 2019-09-30 14:16:45 UTC
The qick patch is not complete.

I still see regressions on build.

1. Xp is still pckced up if installed.

2. Xext is needed only for Xp.

I will work on a complete patch.
Comment 2 Niclas Zeising freebsd_committer 2019-09-30 14:40:18 UTC
Created attachment 207960 [details]
v1

What do you think of this?  I've killed the check for libXp, (the CONFIGURE_ENV stuff), but xext seem to be needed, I get compile errors without it.
Comment 3 commit-hook freebsd_committer 2019-09-30 22:12:28 UTC
A commit references this bug:

Author: dinoex
Date: Mon Sep 30 22:11:27 UTC 2019
New revision: 513425
URL: https://svnweb.freebsd.org/changeset/ports/513425

Log:
  - disable support for libXp
  PR:		240923
  Submitted by:	Niclas Zeising

Changes:
  head/x11-toolkits/lesstif/Makefile
  head/x11-toolkits/lesstif/pkg-plist